
NASA Image 2000      
Users Guide 
 

Basic Operations 
 
Version 1.1 
 
 

 
 
 
 
 
 
 
 
December, 2002 
 
 
 
 
Goddard Space Flight Center 
Greenbelt, Maryland 
 



 

2 



  
 

  3 

Preface 
   

Overview This document provides detailed instructions for using the basic features of 
NASA Image2000.   The NASA Goddard Space Flight Center's (GSFC) Advanced 
Architectures and Automation Branch (Code 588) is developing NASA 
Image2000 for the education programs of the GSFC's Scientific and Educational 
Endeavors (SEE) and the Center for Image Processing in Education (CIPE). 
NASA Image2000 is an image processing software package available on multiple 
platforms, designed to bring high-end scientific image processing capabilities to 
the standard desktop computer (see Minimum Specifications in Section 1.2 for 
limitations for Mac and Unix operating systems).  Developed to meet the needs 
of educators, NASA Image2000 supports the display, analysis and processing of 
satellite imagery. 
  

Audience This guide is written for users who want to perform basic image processing 
using NASA Image2000.   A companion manual, the Image2000 Users Guide: 
Advanced Operations describes some of the more advanced features of the 
system, which allow the user to customize and extend the tool. 
   

Applicability The information in this document corresponds to NASA Image2000 Version 1.1. 
 

For more 
information: 

Copies of this document, along with questions or proposed changes, should be 
addressed to: 
 
J. Breed 
Advanced Automation and Architectures Branch 
Code 588 
Goddard Space Flight Center, Greenbelt, Maryland 20771 
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1.1 What is NASA Image2000? 
 

Why Was 
NASA 
Image2000 
Developed? 

NASA Image2000 is an image processing software package available on 
multiple platforms, designed to bring high-end scientific image processing 
capabilities to the standard desktop computer.  (See Minimum 
Specifications in Section 1.2 for limitations for Mac and Unix operating 
systems.) Developed to meet the needs of educators, NASA Image2000 
supports the display, analysis and processing of satellite imagery. 
 

NASA 
Image2000 
Functionality 

The functionality built into NASA Image2000 was designed to provide the 
capability for the display and analysis of geo-coded satellite imagery.  Users 
can perform standard image processing tasks, similar to those available in 
general graphics packages.  In addition, the system provides other less 
common functions, including (but not limited to) the following:  

 Display pixel intensity, pixel location relative to the image, latitude and 
longitude values and their corresponding projected coordinates (for geo-
coded images only)  

 Non-destructive image annotation including text, symbols, lines and 
polygons, 

 Processing based on a region of interest (ROI), 

 Image math using scalars and other images, 

 Compute image statistics, 

 Generate a histogram,  

 Measurement options including distance, area, perimeter, and angle, 

 Apply map projections, 

 Create, edit, and animate a stack of images, and 

 Create a montage from a stack or from open images.  
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Extending 
NASA 
Image2000 

NASA Image2000 is fully extensible, allowing users to customize the 
program and add new functionality that is developed in-house or by other 
Image 2000 users.  Through its state-of-the-art design, NASA Image2000 
provides a powerful, extensible, platform-independent image processing 
system.    Developed using Java v.2 and Java Advanced Imaging (JAI), it 
allows users to add plug-in operations or macros to extend the existing 
capabilities of the system for nearly any image processing task.   

The design of NASA Image2000 is based upon a plug-in architecture, and 
users can therefore extend the functionality of Image 2000 without changing 
the core infrastructure. Image 2000 provides several ways of adding 
functionality, and includes examples of each method to assist new users.   

In addition to modifying basic functionality in NASA Image2000, it is also 
possible to modify the look-and-feel by customizing the menus and toolbars.  
With relatively little effort, therefore, each user community can have its own 
"version" of Image 2000 that meets its unique needs. 

A companion manual, the NASA Image2000 Users Guide: Advanced 
Operations, describes some of the more advanced features of the system, to 
assist the user in customizing and extending the tool. 
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1.2 What do I need to Use NASA Image2000? 
 

Overview NASA Image2000 is a cross-platform tool, written in Java v.2 and Java 
Advanced Imaging (JAI). The tool is intended to provide advanced scientific 
image processing capabilities on a standard desktop computer. The 
following tables describe the minimum system requirements for using 
NASA Image2000. 
 
NOTE:  Future versions of NASA Image2000 are expected to 

support Macintosh System X.3 and above. Earlier 
Macintosh operating systems do not  provide sufficient 
support for Java, and therefore will not run NASA 
Image2000. 

 

The system requirements for using NASA Image2000 are as follows: 
  

 Required Recommended 

OS Windows XP, as well as 
Windows 98, ME, NT and 
2000.  NASA Image2000 
has been run on Solaris 
and IRIX, but these and 
others such as Mac OSX 
and Linux have not been 
thoroughly tested and are 
not officially supported in 
this release. 

Windows XP, as well as 
Windows 98, ME, NT and 
2000.   

Memory 96 MB RAM 128 MB RAM 

Processor Pentium  Pentium 266 Mhz. (or 
higher) 

Disk Space 2 GB Hard Disk Space 
(total, for software and 
storage of images) 

2 GB Hard Disk Space 
(total, for software and 
storage of images) 

Video 800x600  1024x768 

Minimum 
Specifications: 

Other CD Rom Drive  CD Rom Drive 
 

Note: Future versions of NASA Image2000 are expected to support Macintosh 
System X, which claims to support Java v.2 and JAI.  Earlier Macintosh 
systems do not provide support for the latest versions of Java, and 
therefore will not run NASA Image2000. 
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Minimum 
Specifications 
for 
Installation: 

There is no installer included at this time for MAC OSX (see note above). 

To run the installer you must have 32 MB of free RAM, a minimum of 8-bit 
color depth (256 colors), and a minimum 640 X 480 screen resolution. 
Also, the installation software requires 3 X the amount of disk space 
required by the application it is installing. 

Thus you will also need a minimum of 950MB of hard disk space for the 
"Typical" installation option, although NASA Image2000 once installed will 
only take up 300MB if a Java VM is installed and 265MB otherwise. If you 
plan on installing any of the plugins available in the "Custom" installation, 
their sizes are listed below and you should add those sizes to your 
minimum space needed to install. 

 

The system requirements for using NASA Image2000 are as 
follows: 

  
Plugin Space Used Install Space 

Gaiaxroads  1MB 3MB 

SEE_AVHRR  3MB 9MB 

CDF 4MB 12MB 

HDF 25MB 75MB 

Minimum 
Space Needed 
for Plugins 

FITS 5MB 15MB 
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1.3 Using this Manual 
  

Organization of 
this Manual 

This manual covers Basic Operations for using NASA Image2000.  A companion 
document, which covers Advanced Operations, describes some of the more 
advanced features of the system, to assist the user in customizing and 
extending the tool. The Basic Operations  manual is organized as follows: 

 Section 1 of this document provides introductory material. 

 Section 2 provides basic instructions for getting started with NASA 
Image2000. 

 Section 3 provides instructions for viewing an image, including opening, 
saving, printing, zooming, identifying pixel values and locations, and 
duplicating images. 

 Section 4 provides instructions for enhancing and altering an image in non-
destructive ways, including adding annotations, working with Look Up 
Tables (LUTS), and using overlays. 

 Section 5 provides instructions for defining image properties, such as scale, 
density calibration, and special pixel values, as well as for changing the data 
type and canvas color and creating indexed images. 

 Section 6 provides instructions for performing analysis on images, including 
calculating image and stack statistics.  

 Section 7 provides instructions for enhancing and altering an image in ways 
that actually change image values, including cropping an image, applying 
filters, altering brightness and contrast, inverting images, using histogram 
matching, thresholding, and clamping an image. 

 Section 8 provides instructions for applying mathematical operations to an 
image and using the math calculator to alter images. 

 Section 9 provides instructions for performing geographic transformations 
(e.g., flip, rotate, scale operations) on an image. 

 Section 10 provides instructions for working with multiple images, including 
multi-band images. 

 Section 11 provides instructions for working with stacks, including 
animating stacks, creating montages, and using projections and overlays 
with stacks. 

 

Conventions This document uses the following terms and notational conventions: 
   Indicates a procedure, directing the user in 

performing an action. 
 

  Note: Indicates a note, providing information that may be 
helpful to the user. 

 

   Indicates a Warning, Caution, or very important 
information that users need to know. 
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  bold serif type Indicates menu items, buttons or check boxes that 
perform some action when selected with the mouse.  

Can also indicate window and field titles. 

 

  Italics Indicates system messages displayed to the user.  

  Items in CAPS Indicates a specific key on the keyboard (e.g., TAB or 
ENTER). 

 

  Items in 
brackets < > 

Describes a value supplied by the user or the 
database.  An example is <requirement ID>, where 
the user or the system supplies an actual value. 

 

  Keystrokes When menu selections also may be accomplished 
with a combination of keystrokes, the keystrokes 
(i.e., accelerator functions) are listed parenthetically 
with the menu option (e.g., Select All (Ctrl + A)). 
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2.1 Installing NASA Image2000 
  

Before You 
Begin: 

To install NASA Image2000, you must either have a CD-ROM drive, or access to 
the NASA Image2000 installation through the internet.  We recommend 
installing from CD-ROM if possible, since the installation package is rather 
large and will take longer to download.  Also, please refer to Section 1.2, What 
do I need to Use NASA Image2000, to verify that your system meets minimum 
system requirements for using NASA Image2000. 
 

 To Install NASA Image2000 from CD-ROM: 

1.  Insert the NASA Image2000 CD in the CD-ROM drive.   

The NASA Image2000 Installation program automatically 
runs, displaying the NASA Image2000 installation wizard 
(see Figure 2.1) 

2.  Click on the Install NASA Image2000 button. 

The Installation Wizard runs. 

3.  Follow the directions in the wizard to install the system. You will 
provide the following information: 

•  Your name and organization 

•  The location in your file directory where you want to install 
NASA Image2000 

•  The type of installation you wish to perform (i.e., typical, 
custom or compact). 

In most cases you can accept the defaults provided by the 
installation program. 

4.  After you have provided all necessary information, the 
Installation program will install NASA Image2000 on your system 
in the specified location.  When the installation is complete, you 
may click the Finished button.  NASA Image2000 is installed! 
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Figure 2.1 
 The NASA 

Image2000 
Installation 

Screen 

 
 

 To Install NASA Image2000 from a network: 

1.  Download the installation program from the network, and 
decompress. 

2.  Double-click on the setup.exe file.   

The NASA Image2000 Installation program automatically 
runs, displaying the NASA Image2000 installation wizard 
(see Figure 2.1) 

3.  Proceed as described above. 
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2.2 Starting and Quitting NASA Image2000 
  

Before You 
Begin 

NASA Image2000 should be properly installed on your computer.   

  

 To Start NASA Image2000 in Windows: 

1.  
Click on the Start button on your Windows taskbar.  

2.  Locate the NASA Image2000 application in your Start menu. 

Note: The typical installation has NASA Image2000 located 
at the following path:  Program Files > NASA 
Image2000 > NASA Image2000 

A “splash screen” (see Figure 2.2) will be displayed while the 
system loads.    Then, the NASA Image2000 Main Window will 
open (see Figure 2.3) 

  

Figure 2.2 
 The NASA 

Image2000 
Splash Screen 

   

Figure 2.3 
 The NASA 

Image2000 
Main Window 
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 To Quit NASA Image2000: 
Pull down the File menu and choose Exit. 

 The application will shut down. 
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2.3 NASA Image2000 Windows  
 

Overview The NASA Image2000 interface is composed of a main application window.  
Within the main application window, you may display one or more image 
windows, and/or other NASA Image2000 information/tool windows.   
  

NASA 
Image2000 
Windows  

The standard windows you will use are as follows: 

   

Title Window Description 

Main 
Window 

 

The main application 
window.  All Image frames 
appear within the 
boundaries of this window. 

Tools 

 

The tools window contains 
icon buttons, used to 
access a variety of tools, 
which may be used to 
perform many of the NASA 
Image2000 functions.  See 
Section 2.4 for a 
description of the Tool 
Window tools 
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Image Info 

 

The Image Info window 
provides a great deal of 
important information, 
including the x and y 
location for the selected 
pixel, the real and 
displayed pixel values, and 
the results of 
measurements that have 
been performed on the 
image. 

Image 
Layers 

 

The Image Layers window 
contains information about 
each separate layer of a 
given image.  This window 
also allows you to manage 
image layers, including 
adding new layers and 
removing the layers that 
are no longer needed, as 
well as flattening the image 
so that all layers are 
combined into one. 

LUT 

 

The LUT, or Look Up Table 
window displays the LUT 
currently assigned to the 
image.  In addition, this 
window allows you to 
manage the LUT for the 
image, including editing 
the LUT to highlight 
important image 
information, or loading 
other preexisting LUTs.   

Note:  LUTs are only used 
with single-band 
images (e.g., 
greyscale or 
indexed images). 
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2.4 NASA Image2000 Toolbars 
 

Overview The NASA Image2000 interface provides two main toolbars by default. This 
section describes these toolbars and the features they provide.   
Note: These toolbars are customizable by editing the XML definition 

for the toolbars (see the NASA Image2000 Advanced 
Operations Guide).  

 

Main Window 
Toolbar 

The main NASA Image2000 window contains a selection of commonly used, 
global tools.  This toolbar is always available, although certain tools may be 
disabled based on the context (e.g., the print tool is unavailable if no image is 
open to be sent to the printer).  The tools that appear on this toolbar (by default) 
are as follows: 

 
Tool Function 

 

New Image:   Creates a new, blank image canvas.  You 
can paste in selections from other images, 
and/or enter annotations. 

 

Open Image: Provides a Open File window, allowing you 
to choose an image to open in NASA 
Image2000. 

 

Save Image: Saves the image.  If the image is new, you 
can provide a title and location for the 
image.  Previously saved images are simply 
saved to the original file.  

 

Print Image: Sends the current image to the printer. 

 

Cut: Cuts the selected region of interest, leaving 
a blank background in its place.  The “cut” 
image is placed on the clipboard and may 
be pasted. 

 

Copy: Copies the selected region of interest.  The 
copied image is placed on the clipboard 
and may be pasted. 

 

Paste: Pastes the contents of the clipboard into 
the current image.  The pasted selection 
appears as a new layer in the image, and 
can be manipulated separately. 

 

Measure: Performs measurements on the image, 
which can be used in analysis.  (See 
Sections 6.1-6.4.) 
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Script: Provides an Open File window, allowing 
you to select a preexisting script to run. 
(See the NASA Image2000 Advanced 
Operations  Guide for more on scripting.) 

 

DAG: Opens the DAG editor, allowing you to 
customize NASA Image2000. (See the 
NASA Image2000 Advanced Operations  
Guide for more on the DAG Editor.) 

 
Help: Opens context-sensitive help files to assist 

with using NASA Image2000. 

 

Tools Window The Tools window may be displayed anytime an image is open in NASA 
Image2000.  This toolbar provides a selection of tools useful for manipulating 
images.  The tools in this window are grouped according to purpose.  The tools 
that appear on this toolbar (by default) are as follows: 

 
Tool Function 

 Arrow:   Default Cursor mode. Exits any other 
cursor or tool. 

 Move: Allows the user to “grab” the image and 
move it.   Also moves the “selection” when 
a region of interest is selected.  (The 
defined ROI is moved, not the image area 
selected by the ROI.) 

 Zoom In: Zooms in, magnifying the image. 

 
Zoom Out: Zooms out, reducing the magnification of 

the image. 

 
Find Pixel: Allows the user to move the cursor using 

the arrow keys on the keyboard. 

 

Selection Tools: Allows the user to select a Region of 
Interest (ROI) to manipulate or analyze.  
You can select a rectangle, polygon, line, 
freehand area or circular area. 

 

Annotations: Allows the user to annotate an image, 
using text, predefined iconic graphics, 
rectangles, polygons, freehand drawings, 
circles and/or lines, and to “grab” existing 
annotations to move or delete them.  See 
Section 4.1. 

 

Analysis Tools: Allows the user to plot a profile vertically, 
horizontally or diagonally.  In addition, the 
Angle tool allows the user to measure 
angles.  See Section 6.6. 
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 Miscellaneous: Miscellaneous tools, usually provided 
through plug-ins. 
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2.5 NASA Image2000 Menus 
 

Overview The NASA Image2000 interface provides several main menus by default.   
Note: These menus and menu items are customizable by editing the 

XML definition for the menus (see the NASA Image2000 
Advanced Operations  Guide).  

 
Menu Item Function 

File> The File menu handles most file management tasks.  Items 
under this menu include creating a New file, Opening a file, 
Imports and Exports, Saving files, Closing files, Printing, and 
Exiting the system. 

Edit> Allows you to manage Edits, including the ability to Undo and 
Redo actions, to Cut, Copy and Paste selections, to Duplicate an 
image, to Select All of an image, and to change certain 
Preferences. 

View> Allows you to manage what NASA Image2000 “child” windows 
are open, including the Image Info window, Tools window, 
Layers window, and LUT window (see Section 2.3).  This menu 
also allows you to control the magnification of the displayed 
image (zooming in or out to various percentages).  See Section 
3. 

Image> Allows you to perform various tasks to enhance and alter 
images, and to analyze images.  These features primarily 
operate on a single image, or in comparing two images.  See 
Sections 4 and 5. 

Stack> Allows you to work with a stack of images, including the ability 
to animate a stack, create a montage, use an overlay with a 
stack, or move images in and out of a stack.   

DAG> Allows you to work with Directed Acyclic Graphs (DAGs).  Refer 
to the Advanced Operations  Guide for assistance with creating 
DAGs. 

Special> Provides access to predefined scripts and plugins. 

Windows> Provides control of windows, including the ability to Cascade 
windows and Find Lost Windows. 

Help Provides access to NASA Image2000 online help and the NASA 
Image2000 web site. 
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3.1 Opening an Image 
  

Overview NASA Image2000 supports a wide range of image formats, and allows you to 
open and work with either a single image or multiple images at a given time.   
This section will discuss the basic process of opening a single image.  For help 
with working with multiple images, see Section 7.   
  

 To Open an image file: 

1.  Pull down the File menu and choose Open OR 

Click on the Open icon on the toolbar.   

The Open window is displayed (see Figure 3.1). 

2.   Locate and select the file you wish to open.  

3.  (Optional) Provide the pixel values to be used for Invalid data 
and Transparency. 

4.  (Optional) To provide Geocoding information for geocoded images, 
click on the Geo tab, and provide the geocoding information. 

5.  Click on the Open button to open the image, or on Cancel to 
close the dialog and return to the main window. 
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Figure 3.1:  The 
Open Window 
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Supported 
File Types 

NASA Image2000 supports the following file formats through the standard Open 
File feature.    

•  BMP format (*.bmp) 

•  FPX format (*.fpx) 

•  Generic Image file reader (*.generic) 

•  GIF format (*.gif) 

•  JPEG format (*.jpg) 

•  ERDAS GIS and LAN file reader (*.lan) 

•  PNG format (*.png 

•  PNM format (*.pnm) 

•  Shapefile file reader (*.shapefile) 

•  TIFF format (*.tif, *.tiff) 

•  TOMS ASCII file reader (*.toms) 

•  WBMP format (*.wbmp) 

Note:   The user may customize the system to support other formats, 
using NASA Image2000’s advanced configuration features.  
For information about extending NASA Image2000’s 
capabilities, please refer to the companion document, NASA 
Image2000 User Guide: Advanced Operations . 
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3.2 Saving an Image 
 

Overview Once you have made changes to an image, you can choose to save the changes 
to the original file, to save the changes as a separate file, or to revert to the last 
saved version of the image.   

Note: Due to limitations in the development environment, NASA Image2000 currently 
is unable to save multi-image filetypes (including multi-layer images and 
stacks).  As a workaround, NASA Image2000 gives you a choice of either saving 
the layers/stack images as separate files into a new directory, or saving the 
image as a single image, (which flattens (collapses) all the layers into a single 
RGB layer). 

In addition, NASA Image2000 may be unable to save your image file in the 
image’s original format.  For example, for legal reasons NASA Image2000 is 
unable to save images in the .GIF format, and also is unable to save images in 
the TOMS format.  NASA Image2000 can, however save these files in one of the 
supported formats (e.g., .JPEG or .TIF). 
  

 To Save changes to the original image file: 
 Pull down the File menu and choose Save  OR 

 Click on the Save icon on the toolbar.   

 The changes to the image are saved. 
  

 To Save changes, creating a new image file: 

1.  Pull down the File menu and choose Save As…  

The Save window is displayed (see Figure 3.2). 

2.  Change the file name and/or the location where the file should 
be saved. 

3.  (Optional) Make any necessary changes to the file type by 
selecting the appropriate type from the pop-up list. 

4.  Click on the Save button to save the file under a new name, or 
on Cancel to return to your image without saving. 
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Figure 3.2:  The 
Save Window 

  

 To revert to the last saved version of the file: 
 Pull down the File menu and choose Revert to Saved…  
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3.3 Printing an Image 
 

Overview Images can be printed to your standard printer.  NASA Image2000 does not 
automatically scale the image to fit on a single printed page, however.   In order 
to see how your image will fit, you should first preview the image using Print 
Preview. 

Note: The printing process is a memory-intensive activity.  
Depending on the amount of memory available to NASA 
Image2000, the system may have difficulty printing larger 
images.  

  

 To Preview the printed image: 
 Pull down the File menu and choose Print Preview 

 The Print Preview window is displayed (see Figure 3.3). 
 

Figure 3.3:  The 
Print Preview 
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 To Print the image: 
 Pull down the File menu and choose Print  

  OR 

 Click on the Print icon on the toolbar.   

 The file is sent to the printer. 
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3.4 Zooming and Panning an Image 
  

Overview The hand tool, zoom tools, and zoom commands allow you to view different 
areas of an image at various levels of magnification.  

 The zoom in tool and commands allow you to magnify the view of an image.  
High levels of magnification can allow you to easily see each separate pixel, 
and to perform analysis at a high level of detail. 

 The hand tool allows you to work with an image that is too large, or is 
magnified to a view that is too large to fit in the window frame.  You can use 
this tool to “pan” the image, moving it so that different parts of the image are 
visible in the window frame. 

 The zoom out tools and commands allow you to reduce the view an image.  
You can zoom out to achieve high level, “overall” view of an image that may 
be too large to fit in the window frame. 

  

 To Zoom In: 
  

1.  
Click on the Zoom In tool icon.   

The cursor will change to the magnifying glass. 

2.  Click on the image to increase the magnification OR 

Enter the specific scale factor in the text field at the bottom of the 
tools window 

The image magnification will increase.  The title bar of the 
window will indicate the new magnification (e.g., <400%>). 

3.  (Optional)  Continue clicking on the image until you are satisfied 
with the image magnification.  You can click the UnZoom  button 
at the bottom of the tools window to return to the standard 100% 
view. 

 

 To Zoom Out: 
  

1.  
Click on the Zoom Out tool icon.   

The cursor will change to a magnifying glass with a “+”.. 
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2.  Click on the image to decrease the magnification OR 

Enter the specific scale factor in the text field at the bottom of the 
tools window 

.   

The image magnification will decrease.  The title bar of the 
window will indicate the new magnification (e.g., <50%>). 

3.  (Optional)  Continue clicking on the image until you are satisfied 
with the image magnification.  You can click the UnZoom  button 
at the bottom of the tools window to return to the standard 100% 
view. 

 

 
To move (pan) the view of the image: 

1.  
Click on the Hand tool icon.   

 The cursor will change to the hand. 

2.  Click on the image, and, while holding down the mouse button, 
move the cursor.  

The image will move, changing the field of view.   

3.  Continue moving (or panning) the image until the view of the 
image is satisfactory. 

Note: Double-clicking the hand tool re-centers the image in the image 
frame. 

 

 To magnify or reduce to a specific percentage : 
Pull down the View menu and choose Zoom>, then select the 
appropriate percentage view you wish to use (e.g., 50%, 200%). 

 The magnification will change to the selected magnification. 
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3.5 Identifying Pixel Location, Values and No-Data 
Pixels 

  

Overview It is often useful to identify the exact location and/or value of a given pixel in an 
image.  NASA Image2000 provides the following information about the pixel at 
the cursor location: 

•  The exact pixel location in terms of X and Y coordinates.  

•  The value of the raw data of a given pixel 

•  The value of the pixel’s display (In RGB color) 

In addition, when additional image information is available (such as image 
calibration data or geographical scale) the Image Info window also may provide 
additional information (such as latitude and longitude or calibrated values). 

 
 

 To view the Image Information (including pixel location and values) : 
Pull down the View menu and choose Image Info (Ctrl-I). 

The Image Info window is displayed (see Figure 3.4).  As you 
move your cursor over the image, the X and Y coordinates, Pixel 
Values and RGB Values will change, updating in relation to the 
pixel where your cursor is located. 

Note: The X and Y zero coordinates are located at the top left 
corner of the image.   

  
  

Figure 3.4:  The 
Image 
Information 
Window 
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No-Data Pixels A "no-data pixel" is a pixel whose value has been chosen to represent 
missing or invalid data. For example, in a given image, black pixels (with a 
value of 0) may be defined as no-data pixels. 

The value of the no-data pixel must be explicitly identified.  Some images 
will define the value of no-data pixels in the image’s meta-data.  Otherwise, 
the user must explicitly define the pixel value that will be recognized as a 
no-data pixel.  Then, when viewing the Image Information window, pixels 
with that value may be assumed to represent areas of no data.  
 

 To define the value for “No-data pixels” when opening an image: 
Enter the pixel value to be identified as a no-data pixel in the Invalid 
Data text field.   Then open the image as usual. 

The value you provide will be identified as invalid data, and will not be 
used when performing calculations. 

  

 To identify pixels with no-data value: 

1.  Open the Image Info window:  Pull down the View menu and 
select Image Info. 

The Image Info window is displayed. 

2.  As you move your cursor over the image, the Image Info window 
will update, showing the value of the pixels you identify.   
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3.6 Creating New Images and Duplicating Images  
 

Duplicating 
an Image 

You may at times want to duplicate an image, in order to protect an original 
image and/or to allow you to work with a subset of an image rather than the 
image as a whole.  This process can have several advantages: 

•  In some cases only part of the image is appropriate for the analysis you wish 
to perform.  Working with only the relevant portion of the image can help 
reduce problems with the analysis. Also, large images may be memory-
intensive.  If you can take a part of that image and work with it separately, 
you may improve performance of the system.   In these cases you could 
duplicate the image and crop it to work with the relevant region of interest 
(see Section 4.2). 

•  You may want to experiment with part of an image, without the risk of 
making irreversible changes to your main image.    

  

Before you 
Begin: 

Make sure your source image is open, and is the active window. 

  

 To duplicate an existing image: 
Pull down the Edit menu and select Duplicate. 

A new untitled copy of the source image is displayed.   
 

 

Creating a 
New Image 
from a Subset 
of an Existing 
Image 

While NASA Image2000 does not provide many of the standard drawing or paint 
features found in graphics editing packages, you may want to create new 
images to work with subsets of existing images.  

  

 To create a new image from a subset of an image: 
 

1.  Pull down the File menu and choose New OR 

Click on the New icon on the toolbar.   

 The New Image dialog is displayed (see Figure 3.6). 

2.   Give the image a File Name (e.g., My Image).  

3.  Select the desired Background Color for the image. 

4.  Click on the Ok button to continue, or on Cancel to cancel the 
operation. 

A new, empty image window is displayed. 
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5.  Activate the “source” window, and select the part of the image 
you want to use. 

You may use any of the “selection tools” in the Tools 
window (see Figure 3_7).  

6.  Pull down the Edit menu, and choose Copy (Ctrl-C). 

7.  Activate the new, empty window by clicking on the window. 

8.  Pull down the Edit menu, and choose Paste. 

The selected, copied area of the image is displayed in the 
new image window.  You may now work with that image. 

 

Figure 3.6:  The 
New Image 
Dialog 

 

Note: Currently, NASA Image2000 does not copy and paste from external 
applications.  Therefore you can not view an image in another graphics 
editor, or a browser, for instance, and copy an image from that application 
to paste into an NASA Image2000 image.  You must open the image itself 
using NASA Image2000 in order to use it with NASA Image2000 images. 



4 Changing the Way You See an 
Image 
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4.1 Overview 
 

Overview NASA Image2000 provides many features to allow you to non-destructively 
highlight certain information or sections in an image, while still working with 
the original image data for purposes of measurements and analysis.  Some of 
these changes can be saved separately in a non-destructive manner; others, if 
saved, actually change the image pixel values. 
   

Options The following features are available: 
 

Feature Description How to Save 

Annotations Text and graphic objects 
such as points and lines.  
These annotations are added 
in a separate “layer” in a 
non-destructive manner, and 
you can work with them 
individually, separate from 
the image itself.   

Annotations cannot be saved 
separate from the image.  
Saving is done in a 
“destructive” manner, 
flattening the image and 
replacing the image pixel 
values with those for the 
annotations.  To preserve 
image data, be sure to delete 
annotations before you save 
the image. 

Color Look Up 
Tables 

Indexed color or greyscale 
images can be “recolored” by 
applying a new Look Up 
Table (LUT).  The new LUT 
can be displayed without 
changing the actual pixel 
value, allowing you to 
highlight certain pixel values 
using color without changing 
the data for analyis 
purposes. 

•  LUTs can be saved 
separately and used with 
various images.   

•  By default, pixel data is 
unaffected by a new LUT, 
and the iamge file, if 
saved, maintains its 
original color information. 

•  If the user explicitly 
“Applies” the LUT to the 
image, it actually replaces 
the old pixel values and 
color information.  If the 
image file is saved, the 
new LUT is saved with the 
image, and the original 
color information is lost.   

Adding a Border 
to the Image 

A border can be added 
around the image, allowing 
space for annotations that 
can be saved with the image 
without destroying image 
data. 

If you save the image, the 
border is saved as part of the 
image. 
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Adding a Title 
and Color Key 

A title and color key can be 
added to the image.  NASA 
Image2000 creates a new 
image with the title and color 
key added. 

You can choose to save the 
new image with the title and 
color key, maintaining the 
original image. 

Using Overlays An overlay image can be 
added in a separate layer, 
providing additional 
reference information (e.g., 
geographic landmarks, etc.).  
NASA Image2000 applies 
overlays in a non-destructive 
manner, maintaining pixel 
information for the purposes 
of measurement and 
calculation. 

Currently, if you choose to 
save the image with the 
overlay intact, NASA 
Image2000 flattens the 
image (replacing pixels 
underneath the overlay).  To 
avoid changing pixel data, 
you may choose to remove 
the overlay layer before you 
save. 
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4.2 Annotating and Drawing on an Image 
 

Overview NASA Image2000 allows you to annotate images with text and graphic objects 
such as points and lines.  These annotations are added in a separate “layer” in 
a non-destructive manner, and you can work with them individually, separate 
from the image itself.   It is important to remember, however, that annotations 
are saved in a “destructive” manner; that is, when the image is saved, the text 
and graphics objects will become part of the actual image, and replace the 
image values under them.   

You may wish to expand the size of the image canvas, providing white space 
surrounding the image in which you may place graphics and annotations 
without changing the image itself  (see Section 4.5). 
 

 To add annotations and other drawings to an image: 

1.  Select the annotation tool you want to use from the Tools window. 

2.  Enter your annotation. 

  
If using the Text tool, click in the image, and type in 
the text you wish to use. 

  
If using the Icon tool, select the icon you want to use 
from the bottom of the toolbar, and then click in the 
image where you want the icon to be placed. 

  

If using the Rectangle, Circle or Line tool, click in 
the image at the “starting point” for your object, and, 
holding down the mouse button, drag the mouse 
across the image until the object is the desired size 
and shape. 

 
If using the Polygon tool, click in the image at the 
“starting point” for your polygon, then click again at 
each “angle point”.  Right-click (i.e, click the right 
hand mouse button) when you want to “close off” the 
polygon. 

 

 
If using the Irregular Shape tool, click in the image 
at the starting point, and, holding down the mouse 
button, drag the mouse in the shape you want to 
draw.  NASA Image2000 will draw a line following the 
path of the mouse.  When you want to “close off” the 
shape, simply release the mouse button. 
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 To move a single annotation: 

1.  
Click on the Select Annotation tool  in the Tools Window.   

2.  Click on the annotation you want to move, and, holding down the 
mouse button, drag the annotation to its new location, OR 

Double-click on the annotation.  This brings up a dialog to allow you 
to change x,y location, color, font,  and symbol. 

 

 To delete a single annotation: 

1.  
Click on the Select Annotation tool  in the Tools Window.   

2.  Click on the annotation you want to move. 

3.  Press the Delete button on your keyboard. 

The selected annotation will be deleted. 

Note: You may only move or delete an annotation before the image has been saved.  
Once you save the image, you the annotation becomes a part of the image itself, 
and cannot be moved or deleted without affecting the actual image.   
 

 To delete multiple annotations at once: 

1.  Pull down the Image menu and select Graphics>Show Annotations. 

The Modify Annotations window is displayed (see Figure 4.1). 

2.  Click in the checkboxes beside the annotations to identify the items 
you wish to delete, or click on the Select All, Deselect All, or Invert 
buttons to identify the items to be deleted. 

3.  Click on the Delete button to delete the selected annotations. 

The annotations are deleted and the Modify Annotations window 
updates to show only existing annotations. 

4.  Click on the OK button to close the Modify Annotations window. 
  

Figure 4.1 The 
Modify 
Annotations 
window 
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4.3 Adding/Altering Color Using a Look Up Table 
(LUT) 

 

Overview NASA Image2000 uses color look-up tables (LUTs) to define the displayed RGB 
value of a given pixel.  LUTs can be used to apply color to a grayscale image or 
to redefine the value of a pixel in order to make certain types of image 
information more obvious (e.g., changes in ozone or weather in a satellite 
photo). 
  

Before you 
begin 

LUTs can only be applied to indexed color images or grayscale images.  To find 
out whether your image will accept a LUT:  

1. Pull down the View menu and choose Image Info to display the Image 
Info window. 

2. Look at the Raw Pixel Value. If there is only a single value, then the 
image is either grayscale or indexed.  If there are multiple values 
(usually, but not necessarily three) then the image will not accept a 
LUT.  

 

 To apply a predefined LUT: 

1.  Pull down the View menu and select Lookup Table (LUT)… 

The LUT window is displayed (see Figure 4.2 for an 
example). 

2.  Click on the Load button. 

The Open File window is displayed. 

3.  Select the LUT you wish to apply, and click on the Open button. 

The new LUT is displayed in the LUT window, showing you 
the new RGB display values for each raw pixel value.  The 
image is also updated to display the new values. 

4.  (Optional)  Click the Use as Default checkbox to automatically 
apply the selected LUT to subsequent images. 

As long as the Use As Default checkbox is checked, and the 
LUT window remains open, each additional image that is 
opened will automatically be displayed with the selected 
LUT. 



 4  Changing the Way You See an Image 
 

  47 

 

Figure 4.2:  The 
LUT Window, 
applied to an 
Image (before 
and after) 

Note:  The 
image used is 
a TOMS 
image; the 
“after” LUT is 
TOMS.lut 

< before  after >  

  

Saving (or not 
saving) the 
color changes 

When you load a new LUT, the change in color is to the image display only, and 
will remain in effect only while the image is open.  If you save the image, the 
change in color is not  saved unless you have clicked 'Apply'.  Therefore, if you 
view the image in the Layer window, you will see the old LUT information 
reflected.  You can choose to either make the new color information permanent 
(replacing the image's permanent lookup table with the displayed one), or to 
revert to the old LUT definition. 
 

 To make the LUT definition permanent: 
While viewing the LUT window, click on the Apply button. 

The new LUT definition replaces the image's permanent lookup table 
with the displayed one.  When the image is saved, the LUT definition 
will be saved as well. 

 

 To revert to the former  LUT definition: 
While viewing the LUT window, click on the Revert button. 

The former LUT is displayed in the LUT window, showing you the RGB 
display values, which should now match the raw pixel value.  The 
image is also updated to display the raw pixel values. 
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4.4 Modifying a Look Up Table (LUT) 
  

Overview You may at times find it useful to modify a LUT, in order to highlight certain 
pixel values explicitly.  You can modify a LUT in a couple of ways.  The most 
direct, though at times tedious, way is to edit the LUT itself pixel by pixel, 
defining a new RGB display value for the pixel.  Another method for modifying a 
LUT is density slicing, which allows the user to define a range of pixel values to 
be highlighted by a single color.   
 

 To edit a specific pixel in a LUT: 

1.  While viewing the LUT, click on the Edit button. 

The LUT Editor window is displayed (see Figure 4.3). 

2.  Identify the pixel you wish to edit, either by editing the Index text 
field, or by moving the cursor over the LUT (the Index field will 
update as you move the cursor). 

3.  Identify the new RGB display color for the pixel: 

Update the text fields to define the new color     OR 

Click on the Color Chooser button, and select the color you 
want to use. 

4.  Close the LUT Editor window when you are satisfied with the 
change. 

 

Figure 4.3:  The 
LUT Editor 
Window 

 

 To perform density slicing on a LUT: 

1.  While viewing the LUT, click on the Slice button. 

The Density Slice Editor window is displayed. 
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2.  Identify the range of pixels you wish to edit, either by editing the 
Start Index and End Index text field, or by moving the range 
sliders in the LUT window (the Index field and the image itself 
will update as you move the cursor). 

3.  Identify the new RGB display color: 

Update the text fields to define the new color     OR 

Click on the Color Chooser button, and select the color you 
want to use. 

4.  If you want to define more than one density slice, click on the 
New Slice button, and repeat steps 2, 3 and 4 as needed. 

5.  To delete a density slice, select the slice in the LUT window and 
click on the Delete button in the Density Slice Editor window. 

6.  Close the Density Slice Editor window when you are satisfied 
with the changes. 

 

Figure 4.4:  The 
Density Slice 
Editor, with LUT 
changes 
displayed in the 
image. 

 
 

 To save the edited LUT definition in a new .lut file: 
While viewing the LUT window, click on the Save button. 

The Save window is displayed, allowing you to provide a name for 
the LUT and save it for future use. 

  

Note: LUT's are saved in comma separated value (CSV) format that can be 
imported into many spreadsheets. Image 2000 can also directly import 
ASCII LUT's created by NIH Image. 
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4.5 Adding a Border to an Image 
 

Overview NASA Image2000 allows you to add a border around the image, providing space 
to add annotations, etc. without affecting actual image data.  The border color is 
white, and in the current version cannot be changed. 
 

 To add a border: 

1.  Pull down the Image menu and select Graphics>Border 
Construction…. 

The Border Construction Operation window is displayed 
(see Figure 4.5) 

2.  Provide the dimensions for the Border you wish the image to 
have. 

For example, for a border on the right side of the image of 
100 pixels, enter <100> into the Right Pad text field. 

3.  Select the desired fill Type from the dropdown list.   

4.  Click on the OK button to accept the changes, or on Cancel to 
close the window without adding the border. 

 

Figure 4.5:  The 
Border 
Construction 
Window 
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Figure 4.6:  
Example Border  

   < before  after >  
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4.6 Adding a Title and Color Key to an Image 
 

Overview Often a given color is used to correspond to certain types of image information.  
For example, in a satellite image, certain colors may be associated with various 
temperatures, or elevations.  You can add a title and color key to an image to 
assist with analysis of such images.     
  

 To add a title and color key: 

1.  Pull down the Graphics menu and choose Add Title and Color 
Key… 

The Create a Color Key window is displayed (see Figure 4.7). 

2.  Enter the Legend text in the text field. 

3.  (Optional) Change the first “tic” for the color key. 

4.  (Optional) Change the interval for the tic marks on the color key. 

5.  (Optional) Click on the Background button to change the 
background color for the color key. 

A color picker is displayed.  Select the color you want to 
use, and click on Ok to use the color, or Cancel to close the 
color picker and accept the default background color. 

6.  Click on the Image tab to define the title bar. 

The Image panel is displayed (see Figure 4.7). 

7.  (Optional) Change the Title text. 

8.  (Optional) Change the width for the image border, at the Top, 
Bottom, Left and Right, in pixels. 

9.  (Optional) Click on the Background button to change the 
background color for the color key. 

A color picker is displayed.  Select the color you want to 
use, and click on Ok to use the color, or Cancel to close the 
color picker and accept the default background color. 

10.  Click on the Ok button to create the Title Bar and Color Key, or 
Cancel to close the dialog without performing the operation. 

A new image window is displayed, with a title bar and color 
key (see Figure 4.8).  You may choose to save the new 
image, and the title bar and color key will be saved with the 
image.   
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Figure 4.7 
Create a Color 
Key window: 
Color Key and 
Image panels. 

<Color Key      Image>   
 

Figure 4.8 
Image with Title 
Bar and Color 
Key 

Note:  Sample 
image is a TOMS 
image; defaults 
accepted. 
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4.7  Using Overlays with a Single Image 
 

Overview NASA Image2000 allows you to apply an overlay to a single image.  Overlays can 
be useful when viewing satellite images, to give referential information.  For 
example, you might apply an overlay to show geographical borders on an image 
that displays ozone values, in order to easily identify the location of various 
differences in ozone values. 

Overlays are added in a non-destructive manner, in a separate image layer.  
Therefore, the overlay must match the base image in size and dimension.  In 
addition, the overlay image must be the same image type as the base image.   

Note: If you wish to save your image after an overlay is added, be 
aware that NASA Image2000 “flattens” the image when saving, 
replacing the pixels underneath the overlay with the overlay 
image.  To maintain image data, be sure to remove the overlay 
before saving. 

  

 To add an overlay: 

1.  Pull down the View menu and choose Image Layers. 

The Image Layers window is displayed (see Figure 4.9) 

2.  Click on the Add button in the Image Layers window. 

The Open window is displayed. 

3.  Locate the overlay file you wish to add. 

4.  Type the Transparency pixel value in the text field.  (e.g., 255 for 
white, 0 for black). 

5.  Click on the OK button. 

The overlay is added to the image in a separate layer. 
 

Figure 4.9 
Image Layers 
window with 
sample image 

Note:  Sample 
image is a TOMS 
image; overlay 
file is Latlong.tif 

< before  after >  
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 To remove an overlay: 
Make sure the overlay layer is selected in the Image Layers window 
and click on the Remove button.   

 





5 Defining Image Properties  
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5.1 Setting the Scale 
 

Overview NASA Image2000 allows you to define the spatial scale of a pixel in your image.  
For example, you could choose to define that the length and width of pixels are 
equal to a certain number of kilometers, in order to measure the distance 
represented in the image.   

While some image types include this information by default (e.g., TOMS data or 
geocoded TIF images), for others you will need to explicitly define the scale in 
order to perform useful calculations.  Figure 5.1 illustrates the difference in the 
Image Info window before the image scale is defined, compared to after. 
  

Figure 5.1:  The 
Image Info 
Window, 
unscaled and 
scaled 

< before  after >  
 

 To Set the Scale: 

1.  Pull down the Image menu and select Properties> Set Scale… 

The Set Scale window is displayed (see Figure 5.2). 

2.  If the image is currently not scaled, the Not Scaled radio button 
will be selected.  If so, click on the Scaled radio button to enable 
the Image Scaling. 

3.  Edit the Scaling Data as necessary, to define the Unit, Known 
Distance, Measured Distance (in pixels) and Pixel Aspect 
Ratio.   

For example, you may define that 1 pixel Measured 
Distance is equal to 10 (Known Distance) Kilometers (the 
Unit).   

4.  Click on the appropriate Image Selection radio button to choose 
to Scale all images or to only Scale current image. 

5.  Click on the OK button to set the scale. 
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Figure 5.2:  The 
Set Scale 
Window 
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5.2 Defining Density Calibration 
 

Overview In working with satellite data, you may know the real-world, or geophysical 
values of a few pixels in the image.  NASA Image2000 allows you to define the 
density calibration for an image in order to mathematically relate the 
geophysical values with raw pixel values.  The density calibration can be saved 
to a file, which may then be used for similar types of images (e.g., you may 
define a single density calibration for all images in a single set of data). 

In order to define the Density Calibration, you must know the geophysical value 
of certain pixels in the image (for example, the actual altitude or temperature 
represented by a given pixel).  You will then gather measurements for each of 
those pixels (for example a Mean value for the pixel). 
 

Note: An example of using the density calibration on geophysical image data can 
be found in the Studying Earth’s Environment from Space (SEES) modules 
on Oceanography and Polar Sea Ice Processes (Ex. 1.F).   You can access 
these modules at http://see.gsfc.nasa.gov/edu/SEES.  
 

 To Define the Density Calibration: 

1.  Gather the NASA Image2000 measurements for each of your 
“known” pixels.   

To perform a measurement, select the rectangle selection 

tool  and click on the target pixel, and then click on the 

Measure icon   on the tool bar.  Pull down the Image 
menu and select Analysis>Measurement Table to see the 
results of your measurements. 

2.  Pull down the Image menu and select Properties> Density 
Calibration 

The Density Calibration window is displayed (see Figure 
5.3), displaying the Mean measurements you collected. 

3.  Enter the list of known values next to the appropriate measured 
values in the text boxes at left. 

4.  Enter the Unit of Measure you wish to use in the text box. 

5.  In order to be able to reuse the calibration file in future NASA 
Image2000 sessions, click on the Save button to save the values.  
Give the file a name and click Export to save. 

6.  Click on the radio button for the type of mathematical calibration 
you wish to use.  (Straight Line is a simple linear calibration.) 

7.  (Optional)  Click on the Fit Points button to see the calibration 
graphically. 
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8.  Click on the OK button to accept the Density Calibration and 
close the window. 

The Pixel Value in the Image Info window (View>Image 
Info) will now display the calibrated pixel values. 

 
 

 

Figure 5.3:  The 
Density 
Calibration 
Window 

 
 

 To apply an existing Density Calibration file: 

1.  Pull down the Image menu and select Properties>Density 
Calibration. 

The Density Calibration window is displayed. 

2.  Click on the Open button. 

If the image is already calibrated, NASA Image2000 will ask 
if you want to Overwrite Data.  If so, click OK.  The Load 
Calibration Data window is displayed. 

3.  Locate the relevant density calibration file (it will have a file 
extension of *.csv), and click OK. 

The calibration file is loaded. 

4.  Click on the radio button for the type of calibration you wish to 
use, and, if necessary, type the Unit of Measure in the 
appropriate text box. 

5.  Click on the Fit Points button to see a graphical representation 
of the calibration values, or on OK to use the calibration data. 
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Note: You can also identify an existing density calibration file to use when opening an 
image file.  Simply click on the DensityCal  tab in the Open File window, and 
click on the Calibration File radio button to identify the predefined file. 
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5.3 Changing the Data Type 
 

Overview There are cases in which you may wish to explicitly change the data type of the 
image you are viewing.  For example, in order to perform certain image 
mathematic calculations, the image must be in a compatible data type.  NASA 
Image2000 make it simple to change the image data type. 

Note: Changing the image type may result in lost or altered image 
data.  You may wish to duplicate the image file before 
performing this operation (see Section3.6). 

 

 To Change the Data Type: 

1.  Pull down the Image menu and select Properties>Change Data 
Type. 

The Change Data Type Operation window is displayed (see 
Figure 5.4) 

2.  Select the appropriate data type from the dropdown list. 

3.  Click OK to change the data type. 
 

Figure 5.4:  The 
Change Data 
Type Operation 
Window 

 
 



5 Defining Image Properties 

64 

5.4 Changing the Canvas Color 
 

Overview NASA Image2000’s default canvas color is black.  While this background color is 
rarely obvious, in some cases you may want to change the canvas color.  For 
example, when adding a border to the image, you may want to change the 
canvas/background color to white, to allow you to add annotations without 
affecting image data (see Section 4.5).   
 

 To Change the Canvas Color: 

1.  Pull down the Image menu and select Properties>Set Canvas 
Color. 

The Canvas Color window is displayed (see Figure 5.5) 

2.  Select the color you want to use from the dropdown list. 

3.  Click OK to change the canvas color. 
 

Figure 5.5:  The 
Change 
Canvas Color 
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5.5 Setting Special Pixel Values 
 

Overview NASA Image2000 allows you to define two types of special pixel values.  The 
first type is the “invalid” pixel value.  This special pixel value identifies pixels 
which should be ignored when performing calculations (see Section 3.5).  The 
second type is the “transparent” pixel value.  This special pixel value identifies 
pixels which should be displayed as transparent (for example, in an overlay).   
 

 To Set Special Pixel Values: 

1.  Pull down the Image menu and select Properties>Set Special 
Pixel Values. 

The Set Transparent and Invalid Pixel window is displayed 
(see Figure 5.6) 

2.  Enter the Invalid and/or the Transparent pixel values in the 
appropriate text field. 

Note: In NASA Image2000, black pixels have a value 
of “0”, and white pixels have a value of “255”. 

3.  Click OK to set the pixel values. 
 

Figure 5.6:  The 
Set Transparent 
and Invalid Pixel 
Window 
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5.6 Making an Indexed Image 
 

Overview Indexed formats are mapped to a smaller color palette -- 256-colors or less. In 
an indexed image, colors are stored in a color look up table (LUT), which allows 
you to easily highlight specific features of the image. 

NASA Image2000 allows you to convert non-indexed image to an indexed 
format.  Since this operation inherently causes a loss of image data, you may 
wish to duplicate the image before converting a non-indexed image to an 
indexed format (see Section 3.6). 
 

 To Make an Indexed Image: 
Pull down the Image menu and select Properties>Make Indexed 
Image. 

The image is converted into an Indexed Image.  In the Image Info 
window (View>Image Info), the pixel value now appears with a 
single value (the index value). 

 

Figure 5.7  
Image Info, 
before and 
after 

  < before  after >   
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6.1 Selecting Subregions for Analysis 
 

Overview Much of the analysis performed using NASA Image2000 is performed on 
selected regions of interest (ROI) in the image rather than on the image as a 
whole.  NASA Image2000 provides several tools to allow you to select these 
subregions for analysis in specific ways. 
  

 To select a subregion of an image (or ROI): 

1.  Select the selection tool you want to use from the Tools window. 

2.  Using the tool, make your selection: 

   
If using the Rectangle, Circle or Line tool, 
click in the image at the “starting point” for 
your object, and, holding down the mouse 
button, drag the mouse across the image until 
the object is the desired size and shape. 

Note:   You can use the Rectangle 
selection tool to select a 
single pixel.  With the tool 
selected, simply click on the 
pixel you want to select. 

 
If using the Polygon tool, click in the image at 
the “starting point” for your polygon, then 
click again at each “angle point”.  Right-click 
(i.e, click the right hand mouse button) when 
you want to “close off” the polygon. 

 

 
If using the Freehand tool, click in the image 
at the starting point, and, holding down the 
mouse button, drag the mouse in the shape 
you want to draw.  NASA Image2000 will draw 
a line following the path of the mouse.  When 
you want to “close off” the shape, simply 
release the mouse button. 

3.  Continue with your analysis of the ROI. 

Note: The ROI shape, location and size are displayed in the Image Info window.  The 
subregion selection remains in effect as long as the “marching ants” are visible, 
marking out the borders of the selection. 
 

 To move a selected subregion of an image (or ROI): 

1.  Move the cursor over the selected region.   

The cursor becomes a “hand”   . 

2.  Click and hold down the mouse button while you drag the 
selection area to the appropriate area. 
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 To change the  selected subregion of an image (or ROI): 

1.  Move the cursor over the edge of the selected region.   

The cursor becomes a double arrow   . 

2.  Click and hold down the mouse button while you drag the 
selection area in the direction of arrow to resize the selection.  

Note: ROIs selected with the polygon and freehand selection tools are not resizable . 
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6.2 Measuring Distance and Area and Performing 
Calculations 

 

Overview NASA Image2000 allows you to measure several variables (e.g., area, length, 
pixel mean, standard deviation) for selected regions of interest (ROIs) based on 
that scale. NASA Image2000 supports the following units for measuring length 
and area 

•  Nanometers 

•  Micrometers 

•  Millimeters 

•  Centimeters 

•  Meters 

•  Kilometers 

•  Inches  

•  Feet 

•  Miles 

•  Pixels 

NASA Image2000 also supports Arbitrary Units, allowing user-defined units of 
measurement.  

NASA Image2000’s Measure command also calculates several other 
measurements, including the Image Mean and Standard Deviation, as well as 
the Minor Axis and Major Axis, Angle Measurements, the Coefficient of 
Variables, and the Min and Max. 

Note: You may need to set the scale for the image, so that NASA 
Image2000 can accurately perform the calculations.  See 
Section 5.1. 

 

 To perform measurement and calculations:  

1.  (Optional) Select a subregion of the image to measure (see 
Section 6.1). 

2.  Pull down the Image menu item, and select Analyze>Measure 

The Image Info window (General tab) is updated with the 
measurement. 

Note: You may choose to perform several 
measurements for a given image.  You can view 
all the results of your measurements in a 
Measurement Table.  Refer to Section 6.3 for 
assistance with using the Measurement Table. 



 6  Image Analysis 
 

  71 

 

Figure 6.1: The 
Image Info 
Window, with 
measurement 
results 
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6.3 Viewing Analysis Results in the Measurement 
Table 

 

Overview You may often want to take several measurements (such as measuring distance 
or calculating the image mean and standard deviation) and compare the results.  
NASA Image2000 allows you to customize a Measurement Table, including the 
measurements you want to include and excluding those in which you have no 
interest. 

NASA Image2000 “remembers” all the available measurements, even if they are 
not displayed in the Measurement Table.  You may, therefore, choose to display 
or exclude measurements from the Measurement Table on the fly, without 
losing data or being required to perform the same measurements multiple 
times. 
  

 To view the Measurement Table: 

1.  Pull down the Image menu, and select Analyze>Measurement 
Table. 

 The Measurement Table window is displayed (see Figure 6.2). 

2.  (Optional) To delete a row from the table, select the row and click 
on the Delete button. 

3.  (Optional) To “reset” the table (deleting all rows from the table, 
and erasing the measurements from NASA Image2000 memory). 

4.  (Optional) To change the measurements included in the table 
view, you can customize the table (see below). 

5.  To close the Measurement Table, click on the close box in the 
upper right-hand corner. 

 

Figure 6.2: The 
Measurement 
Table Window 



 6  Image Analysis 
 

  73 

 

 To customize the Measurement Table: 
  

1.  Pull down the Image menu, and select Analyze>Measurement 
Table. 

The Measurement Table window is displayed (see Figure 
6.3). 

2.  Click on the Options button. 

The Measurement Options window is displayed. 

3.  Click on the checkboxes to select or unselect the available 
options, or click on the Select All or Deselect All buttons. 

4.  Click on the OK button to change the options, or on the Cancel 
button to keep the old configuration. 

 

Figure 6.3: The 
Measurement 
Options  
Window 
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6.4 Creating a Histogram of an Image 
 

Overview A histogram provides a graphical representation of the distribution of pixels of 
different pixel values.  A histogram can be generated for either the image as a 
whole, or for a selected region of interest.     
  

 To generate a histogram: 

1.  (Optional) Use a selection tool to select a subregion of the image 
for analysis (see Section 6.1). 

2.  Pull down the Image menu, and select Analyze>Histogram. 

The Generate Histogram Operation window is displayed (see 
Figure 6_4).   

3.  Edit the values as needed. 

4.  Click on the OK button to generate the histogram, or on the 
Cancel button to cancel the operation. 

The Histogram for <File> window is displayed (see Figure 
6_5). 

5.  (Optional for multi-band images) You may click on the 3-band 

icon  to view all three bands at once, or on the 1-band icon 

 to choose a single band to view. 

6.  
(Optional) Click on the Save icon  to save the histogram. 

7.  Click on the close box in the upper right-hand corner of the 
window to close the window. 

  

Figure 6.4: The 
Generate 
Histogram 
Operation 
Window 
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Figure 6.5: The 
Histogram for 
<File> Window 
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6.5 Plotting a Profile of a Single Image 
 

Overview NASA Image2000 provides several graphical tools to allow you to plot a profile 
for a single image.    Plotting a profile allows you to visualize the distribution of 
pixel values between two points on an image.  This type of plot is useful for 
illustrating gradients in various phenomena (e.g., ozone values).   
  

 To Plot a Profile: 

1.  Select the profile tool you want to use from the Tools window. 

2.  Plot your profile: 

   
If using the Horizontal Profile, or the Vertical 
Profile tool, move your cursor over the image 
until you find the x or y axis you want to plot, 
and then click in the image.   

A Horizontal or Vertical Profile window is 
displayed (see Figure 6.6). 

 
If using the Horizontal & Vertical Profile tool, 
move your cursor over the image until you find 
point you want to plot, and then click in the 
image.   

Both a Horizontal and a Vertical Profile 
window are displayed (see Figure 6.7). 

 

 
If using the Segment Profile tool, select the 
icon you want to use from the bottom of the 
toolbar, and then click at the “starting point” for 
your segment, and, holding down the mouse 
button, drag the mouse across the image until 
the segment is the desired size and angle. 

A Profile Segment window is displayed (see 
Figure 6.8). 

3.  (Optional for multi-band images) You may click on the 3-band 

icon  to view all three bands at once, or on the 1-band icon 

 to choose a single band to view. 

4.  
(Optional) Click on the Save icon  to save the profile data to a 
text file.  

You may then import the data into a graphics utility or a 
spreadsheet application. 

5.  Click on the close box in the upper right-hand corner of the 
window to close the window. 
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Note: Once you have plotted a profile, you may choose to leave the Profile window open 
as you continue plotting profiles.  The window will update with the new values for 
each profile. 
 

Figure 6.6: The 
Profile Window 

 
 

Figure 6.7: The 
Horizontal and 
Vertical Profile 
Windows 

 
 

Figure 6.8: The 
Segment Profile 
Window 
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7 Enhancing and Altering an 
Image 
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7.1 Cropping an Image 
 

Overview NASA Image2000 allows you to crop an image either based on a selected region 
of interest, or based on user-supplied pixel values.   
  

 To crop an image based on a region of interest: 

1.  Use the selection tools (available in the Tools window) to select 
the area to which you wish to crop the image.  (The area inside 
the selection will be retained, everything outside the selection will 
be removed.) 

2.  Pull down the Image menu and select Graphics>Crop Image. 

The image is cropped to the selected area.  (See Figure 7.1). 
 

Figure 7.1:  
Image Cropped 
by Selection 
(Before and 
After) 

    
 

 To crop an image based specific pixel locations: 

1.  With no region of interest selected, pull down the Image menu and 
select Graphics>Crop Image. 

The Crop Image Operation window is displayed (see Figure 
7.2). 

2.  Enter the X and Y initial values (the upper left-hand pixel location 
for the cropped area). 

3.  Enter the X and Y final values (the lower right-hand pixel location 
for the cropped area). 

Note: The initial and final pixel location define a 
rectangular region of interest. 
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4.  Click the OK button to continue with the crop operation. 

The image is cropped according to your specification (see 
example in Figure 7.3). 

 

Figure 7.2:  Crop 
Image 
Operation 
Window 

 
 

Figure 7.3:  
Image Cropped 
by Defined 
Pixels (Before 
and After) 
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7.2 Applying Filters 
 

Overview NASA Image2000 provides several filters to allow you to improve image quality.   
The effects of these filters can be quite subtle or dramatic, depending on the 
image you are working with.  
   

Options The following filters are available: 
 

Blur Blurring is used to reduce spurious effects in an image due 
to poor sampling (e.g. aliasing) or a poor transmission 
channel (noise).   This filter blurs the edges in an image. 

Heavy Blur See above. 

Sharpen Sharpening is used to enhance detail in a blurred image 
(such as a scanned image). The simple sharpening filter not 
only enhances edges, but also enhances noise. More 
sophisticated filtering is required to limit the effect to edges. 

Find Edges Edge Detection is typically used as another sharpening 
method, or as the first step in creating an outline mask from 
a image. 

Median 
Filtering… 

Median Filtering is used to reduce or eliminate shot or 
impulse noise (also called speckle).  

User Defined… Users can define their own filter to achieve customized 
effects. 

 

 To apply basic filters (Blur, Heavy Blur, Sharpen, and Find Edges): 

1.  Pull down the Image menu and select Enhancement>Filters>. 

2.  Select the Filter menu item you wish to apply.   

The selected filter is applied to the image. 
 

 To apply Median Filtering: 

1.  Pull down the Image menu and select Enhancement>Filters> 
Median Filtering... 

The Median Filter Operation window is displayed (see 
Figure 7.4). 

2.  Select the desired Mask Shape from the dropdown list. 

3.  Enter the Mask Size in the text field. 

4.  Click on the OK button to apply the mask, the Cancel button to 
cancel the operation. 
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Figure 7.4: 
Median Filter 
window with 
original Image, 
and Image with 
Median Filter 
applied. 

                      
 

User Defined 
Filters 

User defined filters use the Convolution operator. The Convolution operator 
uses two-dimensional matrix (called a kernel) to compute each output pixel by 
placing the matrix element at (X_origin, Y_origin) over the corresponding pixel in 
the source image, then summing the products of each matrix element with the 
source pixel that lies under it.  

The values of the kernel elements determine the operation of the filter (see the 
advanced guide for details). A Box filter is a special case in which all elements of 
the kernel have the same value. This is the simplest type of blurring (or low-
pass) filter. If the Normalize box is checked the sum of all elements in the kernel 
is the same as the Constant. 
 

 To apply a User Defined Filter: 

1.  Pull down the Image menu and select Enhancement>Filters> 
User Defined... 

The Convolve window is displayed (see Figure7.5). 

2.  Enter the desired Width and Height in the text boxes. 

3.  Enter the desired X Origin and Y Origin pixel locations. 

4.  Provide the Kernal Data for the filter. 

5.  (Optional) Click on the Load button to select a preexisting 
Kernal. 

6.  (Optional) Click on the Box Filter button to use a box filter, and 
provide a constant. 

7.  Click on OK to apply the filter, or on Cancel to cancel the 
operation. 
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Figure 7.5: User 
Defined Filter 
window 
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7.3 Altering Brightness and Contrast Manually 
 

Overview While the look-up table (LUT) is useful for altering the color value of grayscales 
and indexed images, you may at times want to visually enhance multi-band 
images, without changing them to indexed color (which can result in a 
degradation of image quality).  The Brightness/Contrast Adjuster provides this 
ability. 

The Brightness/Contrast Adjuster allows you to make simple adjustments to 
the brightness and contrast of the image as a whole.  In addition, you can 
modify the brightness and contrast values of each RGB band individually.   
 

 To modify the brightness and contrast values of the image: 

1.  Pull down the Image menu, and choose 
Enhancement>Brightness and Contrast. 

The Brightness/Contrast Adjuster window is displayed (see 
Figure 7.6). 

2.  Move the “sliders” to adjust the brightness and contrast values. 

Move the sliders to the right to increase the value, or to the 
left to decrease it.  The image will update as you adjust the 
values. 

3.  (Optional) Click on the Histogram button to view the image 
values as a histogram. (Refer to Section 6.4 for more on 
histograms.) 

4.  (Optional) Click on the Apply button to apply the new values to 
the image or on the Revert button to return to the original 
values. Click on the Close button to close the window. 

You can choose to close the window without permanently 
applying the new values to the image.   If you choose to 
apply the new values to the image, the intensity scale will 
update, using the new values as the “norm”.  

 

Figure 7.6: The 
Brightness/ 
Contrast 
Adjuster 
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 To modify the brightness and contrast values of specific RGB bands: 

1.  While viewing the Brightness/Contrast Adjuster, click on the 
RGB Adjust tab. 

The RGB Adjuster tab is displayed (see Figure 7.7), 
providing specific control over the Red, Green and Blue 
bands. 

2.  Move the “sliders” to adjust the brightness and contrast values. 

Move the sliders to the right to increase the value, or to the 
left to decrease it.  The image will update as you adjust the 
values. 

3.  (Optional) Click on the Apply button to apply the new values to 
the image or on the Revert button to return to the original 
values. Click on the Close button to close the window. 

You can choose to close the window without permanently 
applying the new values to the image.   If you choose to 
apply the new values to the image, the changes become 
permanent, and you cannot revert to the original values.  

 

Figure 7.7: The 
RGB Adjust tab 
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7.4 Altering Brightness/Contrast through Auto Adjust 
 

Overview NASA Image2000 provides the ability to alter the Brightness and Contrast of 
multi-band images using automated adjustments based on mathematical 
calculations.   

Note: This feature is not available for grayscale or indexed images.   
  

 To use the NASA Image2000 automated adjustment features: 

1.  While viewing the Brightness/Contrast Adjuster, click on the 
Auto Adjust tab. 

The Auto Adjuster tab is displayed (see Figure 7.8). 

Note: The Auto Adjust features are only available for 
multi-band images.  The tab will not appear for 
grayscale or indexed images. 

2.  Select the radio button for the automated adjustment you wish to 
use: 

•  Linear Stretch: 

  Enter the Cutoff <amount> of peak value in the text field. 

•  Histogram Normalization:  

 Enter the Mean and Standard deviation values in the text 
field. 

•  Histogram Equalization   

3.  Click on the Adjust button to perform the change. 

Note: Once you perform the automated adjustments, 
you cannot revert to the original values.  You 
must close the image (without saving), or use 
File->Revert to Saved to get back to the 
original image. 
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Figure 7.8: The 
Auto Adjust Tab 
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7.5 Invert an Unsigned Image  
 

Overview The Invert feature creates a negative of an image.  You can use the Invert 
command to create a positive image from a scanned negative, or to create a 
negative from a positive image.  It is also used to get better contrast in X-ray or 
MRI images.   

When you invert an unsigned image, the brightness value of each pixel is 
subtracted from the maximum pixel value for it's data type..  For example, an 8-
bit pixel with a value of 255 (white) is changed to 0 (black). A color pixel with a 
value of 207/62/45 (a bright red on the RGB bands) is changed to 48/193/210 
(a light blue).  This command is usually used with grayscale images, since the 
results can be rather odd when the command is applied to a color image. Also, 
for signed images, invert multiplies every pixel by -1 

Note: Be aware that the Invert feature changes the Image’s actual raw pixel values, 
rather than simply changing the way the image is displayed.  If you decide you 
wish to revert to the original pixel values, you can perform an “Undo” 
immediately after inverting the image.  If you perform other operations, 
however, you will have to revert to the saved version of the image to retrieve the 
original pixel values.  You may wish to Duplicate the image before performing 
the operation.  (See Section 3.6) 
  

 
To invert an unsigned image:  

 Pull down the Image menu and select Enhancement>Invert 

The pixel values are inverted (see Figure 7.9 for an example). 
 

Figure 7.9: 
Original Image, 
and Image with 
Invert 
command 
applied 
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Note: You can also invert an image by applying an inverted color look-up table 
(LUT). The LUT does not modify the raw pixel value while the actual Invert 
command does. Applying a LUT, therefore, is a useful way of changing way 
the image is displayed without actually changing the image itself (in the 
value of the pixels themselves). Applying a LUT, however, will only work on 
grayscale or indexed images.  

For help with applying a LUT, refer to Section 4.3.  To invert a greyscale 
image using a LUT, use the predefined LUT “I2kGrayInverted”, which is 
provided with the NASA Image2000 installation. 
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7.6 Using Histogram Matching to Alter an Image 
 

Overview One enhancement tool, using the histogram, is the Histogram Equalization 
feature.  Histogram Equalization employs a re-assigns the intensity values of 
pixels in the input image such that the altered image contains a uniform 
distribution of intensities (i.e. a flat histogram). This technique is used in image 
comparison processes (because it is effective in detail enhancement) and in the 
correction of non-linear effects introduced by, say, a digitizer or display system.  
 

 To use Histogram Equalization to alter an image: 
Pull down the Image menu and select Enhancement>Histogram 
Matching>Histogram Equalization. 

The image is altered, with the histogram equalized. (see Figure 
7.10) 

 

Figure 7.10:  
Image, before 
and after 
Histogram 
Equalization 

Note:  The 
image used is 
moon-sm.jpg 

before >  

  

after >  
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7.7 Thresholding an Image 
 

Overview NASA Image2000’s Thresholding feature allows you to separate out the regions 
of the image corresponding to important objects, from the regions of the image 
that correspond to background.  You can perform this segmentation on the 
basis of the different intensities or colors in the foreground and background 
regions of an image.   In addition, thresholding also allows you to see what 
areas of an image consist of pixels whose values lie within a specified range, or 
band of intensities (or colors).  

NASA Image2000’s Thresholding feature allows you to specify the low and high 
ends of the pixel value you wish to isolate, and to assign a specific pixel value to 
any pixels that fall within that range.  This feature in many ways results in a 
display similar to a Density Slice operation.  The difference, however, is that the 
Thresholding operation changes the actual pixel value, as opposed to simply 
changing the image display.  Thresholding, therefore will actually change the 
results of measurements and calculations, where Density Slicing will not. 
 

 To perform the Thresholding operation on an image: 

1.  Pull down the Image menu and select Enhancement> 
Thresholding. 

The Threshold operation window is displayed (see Figure 
7.11). 

2.  Enter the Low value in the Low text field (this is the lower end of 
the spectrum you want to isolate). 

3.  Enter the High value in the High text field (this value is the high 
end of the spectrum you want to isolate). 

4.  Enter the Value in the Value text field (this is the pixel value you 
want to use to display the thresholded segment of pixels). 

For example, if you enter “0” in the Value field, all pixels 
with a value that falls within your low and high values will 
be displayed as black.  If you enter “255”, all the pixels will 
be displayed as white.   

5.  Click OK.   

The image pixels which fall within the defined range are 
changed to correspond with the defined display value.   

 

Note: For RGB (non-indexed) images, you can enter these values for each color 
channel, allowing you to isolate pixels within a given colorspace. 
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Figure 7.11:  
Threshold 
Operation 
Window 
(indexed or 
single-band 
image) 

  
 

Figure 7.12:  
Image, before 
and after 
Thresholding 

Note:  The 
image used is 
a Sea 
Surface 
Temperature 
image in .tif 
format, 
thresholded 
using the 
values shown 
in Figure 7.11.  

before >   

after >    
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7.8 Clamping an Image 
 

Overview NASA Image2000 allows you to “clamp” the values in your image.  The Clamp 
operation sets all the pixels whose value is below a "low" value to that low value 
and all the pixels whose value is above a "high" value to that high value. The 
pixels whose value is between the "low" value and the "high" value are left 
unchanged.  

Like Thresholding, this feature allows you to eliminate unimportant image 
information, isolating or highlighting the pixels you wish to work with. 
 

 To perform the Clamp Values operation on an image: 

1.  (Optional)  Use the image selection tools to select the region of 
interest for which you wish to clamp values.  

2.  Pull down the Image menu and select Enhancement> Clamp 
Values. 

The Clamp Values operation window is displayed (see 
Figure 7.13). 

3.  Enter the “low” and “high” values you wish to use. 

4.  Click OK. 

The image pixel values are clamped to the parameters you 
set. 

 

Figure 7.13:  
Clamp 
Operation 
Window 
(indexed or 
single-band 
image) 
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Figure 7.14:  
Image, before 
and after 
Clamping 

Note:  The 
image used is 
a Sea 
Surface 
Temperature 
image in .tif 
format, with 
image data 
selected and 
clamped 
using the 
values shown 
in Figure 7.13.  

before >   

after >   
 
 





8 Applying Math Operations to an 
Image 
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8.1 Using Math Operations to Alter Images 
 

Overview NASA Image2000 provides several math operations, which can be used to 
manipulate images.  These operations modify the image according to user-
directed mathematical calculations.   
  

Arithmetic 
Operators 

NASA Image2000 provides the following Arithmetic Operator options for the 
mathematical manipulation of images.  
Absolute Value This returns the absolute value of an image. If a pixel value is 

negative it will return the same number but it will be positive. 
Positive values remain unchanged. 

Exponent This applies the exponential method ex. A pixel value of 1 will 
return 2.71828. 

Logarithm(ln) Returns the natural logarithm of each pixel in the image. It is 
the inverse of the exponential function. 

Add Constant This adds a user-supplied constant to the pixel value. If the 
constant is 10, then 10 will be added to all of the pixels in the 
image (x + 10). 

Subtract 
Constant 

This subtracts a user-supplied constant from the pixel value. If 
the constant is 10, then 10 will be subtracted from all of the 
pixels in the image (x - 10). 

Subtract from 
Constant 

This subtracts a pixel value from a user-supplied constant. If 
the constant is 10, then the pixel value will be subtracted from 
10 for all of the pixels in the image (10 - x). 

Divide by 
Constant 

This divides a pixel value by a user-supplied constant. If the 
constant is 10, then the pixel values will be divided by 10 for 
all of the pixels in the image (10 / x). 

Divide Into 
Constant 

This divides a user-supplied constant by the pixel value. If the 
constant is 10, then 10 will be divided by all of the pixels in the 
image (x / 10). 

Multiply 
Constant 

This multiplies a user-supplied constant by the pixel value. If 
the constant is 10, then 10 will be multiplied by all of the 
pixels in the image (x * 10). 

  

Logical 
Operators 

NASA Image2000 provides the following Logical Operator options for the 
mathematical manipulation of images.  

Note: These are all binary operations.For the examples, 15 = 
00001111 in binary and 225 = 11100001 

AND to 
Constant 

This compares two numbers and if the corresponding bits are 
the same (both 1 or both 0) then the output bit equals the 
value of those bits. If the bits are different then the output bit 
is 0. Example: 00001111 AND 11100001 = 00000001. 
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OR to 
Constant 

This compares two numbers and if either of the corresponding 
bits equal 1 then the output bit equals 1. If both bits equal 0 
then the output bit is 0. Example: 00001111 OR 11100001 = 
11101111. 

XOR to 
Constant 

This compares two numbers and if both of the corresponding 
bits are the same then the output bit equals 0. If one of the 
bits equal 0 then the other equals 1 the output bit is 1. 
Example: 00001111 XOR 11100001 = 11101110. 

  

Relational 
Operators 

NASA Image2000 provides the following Relational Operator options for the 
mathematical manipulation of images.  

Note: These operations all require two images. 
Minimum… This compare the two images and for each pixel returns the 

minimum value (from the two images). Example, x1 = 10, x2 = 
45 output = 10. 

Maximum… This compare the two images and for each pixel returns the 
maximum value (from the two images). Example, x1 = 10, x2 = 
45 output = 45. 

 

 To perform Math Operations: 

1.  Pull down the Image menu and select Math> <Selected 
Operation Type> > <Selected Operation>. 

2.  (Optional, depending on operation selected)  Provide the constant 
to be used in the operation.  Click OK to perform the operation. 
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8.2 Using the Math Calculator to Alter Images 
  

Overview  The NASA Image2000 Calculator provides an equation to process two images. 
The user has to fill in the image names, operation, and scale and offset values.   
The result is an image that is a combination of the two images, calculated based 
on the values you provide. 

The values you need to provide in the calculator are as follows: 
Scale Scale is simply a number that is multiplied by an input image 

and/or the result. If the image or result should not be affected 
by scale then "1.0" should be entered. 

Operation Operation is the action you want to perform with the two 
images. For example, a user could add two images together. 

Offset Offset is a number that is added to the result. If the result 
should not be affected by offset then the number should be 
"0.0"  

Real Result Real Result should be check if the resulting image should have 
floating point numbers. If this is not checked, the output image 
will have integer format. 

 

 To use the Math Calculator: 

1.  Pull down the Image menu and select Math> Calculator… 

The Calculator window is displayed (see Figure 8.1). 

2.  Select the images you want to use from the Image 1 and Image 2 
dropdown lists, or click on the  “…” button to select an image 
that is not currently open. 

3.  (Optional) Provide the Scale and Offset values as needed. 

4.  Select the Operation you wish to perform from the dropdown list.

5.  (Optional) Edit the Result field to provide a different title for the 
result image. 

6.  (Optional) Check the Real Result checkbox if the image should 
have floating point numbers.  If this is not checked, the output 
image will have integer format. 

7.  Click on the Execute button to perform the operation. 
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Figure 8.1: The 
Image 
Calculator 
Window 
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9.1 Applying  Map Projections to an Image 
 

Overview Map projections are used to represent a spherical object (like the Earth) on a 
flat surface like paper or a computer screen.  Unprojected map images are very 
distorted. For example, the surface area of a pixel on the equator may differ 
greatly from the surface area of a pixel near the poles.  Map projections 
minimize these distortions.  NASA Image2000 provides three map projections 
operations, which may be used with geocoded images.   
 

Options The following map projection operations are available: 
 

Unprojected 
(lat/lon) 

Used to remove projections, 
returning the image to the 
original lat/lon image. 

Goode This projection is used to 
display global data.  The 
projection is an equal area 
projection, but the globe is 
interrupted so that all of 
the land masses (except 
Antarctica) are continuous, 
which helps to preserve the 
shape of land masses. 

Hammer This projection is also used 
to display global data, but 
the globe is presented as a 
continuous feature.  You 
have the option to define 
the center longitude for the 
projection, which allows 
you to control the portion 
of the globe that appears in 
the center of the image 
window. 
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Polar This projection shows the 
North or South poles of the 
Earth as viewed from deep 
space.  The polar regions 
are often severely distorted 
by other projections.  This 
projection allows you to 
choose to view the North or 
South Pole.  

  

Before you 
begin 

Make sure the image you are using is a geocoded image.  You may define 
geocoding information for certain images when opening the image.  See Section 
3.1.   
 

 To apply a map projection: 

1.  Pull down the Image menu, select Geographic 
Transformations> Map Projections>, and choose the desired 
projection menu item. 

2.  (Optional) If you selected Goode, no further parameters are 
necessary. 

The image is updated, with the Goode projection applied. 

3.  (Optional) If you selected Hammer, enter the Reference Longitude 
in the text box, and click OK. 

The image is updated, with the Hammer projection applied. 

4.  (Optional) If you selected Polar, choose the appropriate radio 
button for either the North or South Pole, and click OK. 

The image is updated, with the Polar projection applied. 
 

 To remove a map projection (displaying the unprojected image): 
Pull down the Image menu, select Geographic Transformations> Map 
Projections, and choose Unprojected (lat/lon).   

  The image is updated, displaying the unprojected image. 
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9.2 Flip Image 
 

Overview NASA Image2000 allows you to “flip” an image horizontally, vertically and/or 
diagonally.    
  

Flip Image 
Effects 

The effects of the options in the Flip Image operation are as follows: 

Flip 
Horizontal 

  becomes    

Flip 
Vertical 

  becomes    

Flip 
Diagonal 

  becomes    
 

 
To flip an image:  

1.  Pull down the Image menu and select Geometric 
Transformations> Flip Image. 

The Flip Image window is displayed (see Figure 5.1). 

2.  Select the Type of flip from the dropdown list. 

3.  Click on the OK button to flip the image, or on Cancel to cancel 
the operation. 

The image is flipped accordingly. 
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Figure 9.1: The 
Flip Image 
Window 
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9.3 Skew Image 
 

Overview 
NASA Image2000 allows you to skew (or shear) an image horizontally or 
vertically.  This feature also allows you to define the method for interpolation.   
Interpolation provides a way of adjusting the pixel size of an image without 
producing pixelisation (jaggies)  You may select the mathematical formula used 
to calculate the color of the missing pixels based on the color of surrounding 
pixels.  
  

Skew Image 
Effects 

The effects of the options in the Skew Image operation, both with a Shear 
value of 1.0, are as follows: 
Skew 
Horizontal 

  becomes    

Skew 
Vertical 

  becomes    
 

 
To skew an image:  

1.  Pull down the Image menu and select Geometric 
Transformations> Skew. 

The Skew Operation window is displayed (see Figure 5.2). 

2.  Enter the Shear value. 

3.  Select the Shear Direction of flip from the dropdown list. 

4.  Select the Interpolation method from the dropdown list. 

5.  Click on the OK button to skew the image, or on Cancel to cancel 
the operation. 

The image is skewed (or sheared) accordingly. 
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Figure 9.2: The 
Skew Operation 
Window 
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9.4 Translate Image 
 

Overview NASA Image2000 allows you to translate the image, shifting the origin of the 
pixels by a user-defined value.  The effect of the operation is to shift the image 
down and to the right.  The size of the image frame does not change, so the right 
and bottom edge of the image is trimmed by the user-defined number of pixels. 
  

Translate 
Image Effects 

The effect of the Translate Image operation, with X-Translation and Y-
Translation values of 5 (in other words, with the origin pixel shifted by 5 
pixels in each direction) is as follows: 

Note: A border is placed around the image to highlight the change 
in the image. 

  becomes    
 

 To Translate an image:  

1.  Pull down the Image menu and select Geometric 
Transformations> Translate. 

The Translate Operation window is displayed (see Figure 
5.3). 

2.  Enter the X-Translation value. 

3.  Enter the Y-Translation value. 

4.  Select the Interpolation method from the dropdown list. 

5.  Click on the OK button to translate the image, or on Cancel to 
cancel the operation. 

The image is translated accordingly. 
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Figure 9.3: The 
Translate 
Operation 
Window 
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9.5 Rotate Image 
 

Overview NASA Image2000 allows you to rotate the image, turning it to a user-defined 
degree.   Currently this process is performed based on user-defined pixel values 
to a specifically defined angle degree.  A future version of NASA Image2000 may 
provide the ability to directly rotate the image. 
  

Translate 
Image Effects 

The effect of the Rotate Image operation, to an angle in degrees value of 90 is 
as follows: 

  becomes    
 

 To Rotate an image:  

1.  Pull down the Image menu and select Geometric 
Transformations> Rotate. 

The Rotation Operation window is displayed (see Figure 5.4). 

2.  Enter the X-Origin value. 

3.  Enter the Y-Origin value. 

4.  Enter the Angle in degrees. 

5.  Select the Interpolation method from the dropdown list. 

6.  Click on the OK button to rotate the image, or on Cancel to cancel 
the operation. 

The image is rotated accordingly. 



 9  Applying Geometric Transformations 
 

  113 

 

Figure 9.4: The 
Rotation 
Operation 
Window 
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9.6 Scale Image 
 

Overview NASA Image2000 allows you to scale an image, increasing or decreasing its size.  
You can choose to scale the x and y values proportionately, or separately.   

The Scale Image operation has an effect similar to zooming in or out on the 
image (see Section 3.4); the difference, however, is that the Scale image actually 
changes the value of the image, while the zoom merely displays the image 
magnified or shrunk.    
 

 
To scale an image:  

1.  Pull down the Image menu and select Geometric 
Transformations> Scale Image. 

The Scale Image window is displayed (see Figure 5.5). 

2.  Enter the X-scale factor.   

The number entered should be a decimal value of the 
percentage (e.g., to scale to 50%, enter <.5>; to scale to 
120%, enter <1.2>. 

3.  Enter the Y-scale factor. 

The number entered should be a decimal value of the 
percentage (e.g., to scale to 50%, enter <.5>; to scale to 
120%, enter <1.2>. 

4.  (Optional) Enter the X-Translation value. 

5.  (Optional) Enter the Y-Translation value. 

6.  (Optional) Select the Interpolation method from the dropdown 
list. 

7.  Click on the OK button to scale the image, or on Cancel to cancel 
the operation. 

The image is scaled accordingly. 
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Figure 9.5: The 
Scale Image 
Window 
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10.1 Opening Multiple Images at Once 
 

Overview You may often wish to work with multiple images at a time, either to compare 
and analyze images or to combine multiple images into a stack, in which the 
images are opened and arranged in a single window in layers.  Usually a stack 
is comprised of a number of the same type of images (e.g., 12 monthly images of 
sea surface temperature are opened in a stack), and can be animated.  (Refer to 
Section 11, Working with Stacks).  You can, of course, open each image 
individually, but with some advance preparation you can also open a group of 
images in one single operation.   

In the current version of NASA Image2000, you cannot open multiple images by 
multi-selecting them in the File:Open dialog.  (This limitation is due to a Java 
bug, which may be corrected in a future version of Java).  NASA Image2000 
does, however, allow you to select a “folder” or directory to be opened, and the 
system will in that case open all images contained in the selected directory.  
You may choose between several options as to how the system will open the 
images: 

•  Create a Multi-band image, placing each image in separate layers.  This 
option gives you several options as to how to display the various color bands 
contained in the source images. 

•  Open the Images as separate Images.  This  option allows you to work with 
each image as a single image in a separate image frame, and therefore 
provides several options that are not available when working with images in 
a stack. 

•  Open the images as a Stack.  This option allows you to work effectively with 
overlays, and to animate images.  Some options for analyzing images are not 
available when working with Stacks, but you can choose to extract the 
images from the stack into separate windows at a later time if you wish. 

  

 To open multiple images at once: 

1.  Make sure the images you want to open are located in a single 
“folder” or directory. 

Note: Remember that all the images in the directory 
will be opened.  So the directory should contain 
all the images you want to open, but only the 
images you want to open. 

2.  Pull down the File menu and choose Open  OR 

Click on the Open icon on the toolbar.   

The Open window is displayed (see Figure 10.1). 

3.   Locate and select the directory you wish to open.  
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4.  Click on the Open button to open the images, or on Cancel to 
close the dialog and return to the main window. 

The Open Directory dialog is displayed (see Figure 10.2). 

5.  Select the appropriate radio button to open the contents of the 
directory  as a Multi-Band image, to simply open All Images, or 
to open the contents a Stack. 

6.  Click on the OK button to continue, or the Cancel button to 
cancel the operation. 

The images are opened in the manner you chose.   

Note: Refer to Section 10.2 for help with working with 
Multi-Band images.   

 

Figure 10.1: The 
File:Open 
Window 

 
 

Figure 10.2: The 
Open Directory 
Window 
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10.2 Working with Multi-Band Images 
 

Overview  When you choose to open a directory of images as a Multi-band image, you 
have the option of opening the images as a single multi-layer image or as 
separate images.  If you choose to open the images as a multi-layer image, you 
can select which bands are to be loaded or which bands are used to form a color 
composite. Also, the layers are known to be coregistered so that analysis can be 
performed on one layer while viewing another by making the layer of interest 
current. 
 
There are several constraints to working with multi-band images: 

•  Images in a multi-band image generally originate from a single multi-
spectral instrument (such as Landsat or AVHRR) and are geographically 
coregistered, 

•  The images in a multi-band directory must all be single banded images  

•  If any of the images in a multi-band directory are GeoTIFF they must all be 
GeoTIFF and have the same GeoTIFF encoding. 

A typical scenario is to load an RGB composite in one layer, placing that layer 
on top and using visible features as a guide for performing analysis in the lower 
layers, which may contain thermal or ultraviolet data.  
 

 To open a multi-banded image as a multi-layer image or as separate images: 

1.  Open a directory of images as a Multi-Band Image (see Section 
10.1). 

The Open Multi-Banded image window is displayed.   

2.  Select the bands you wish to use in your image by clicking on the 
check boxes in the Band Selection tab (see Figure 10.3). 

3.  Select the appropriate radio button to determine whether the 
images will be open as a Multi-Layer image or as Separate 
Images. 

4.  Click on the Apply button to generate an image based on your 
selection (you can do this several times) and/or on the OK button 
to generate the image and close the dialog window. 
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Figure 10.3: The 
Open Multi-
Banded Image 
Window: Band 
Selection 

 
 

 To open a multi-banded image as RGB color composite image (with or 
without an alpha channel): 

1.  Open a directory of images as a Multi-Band Image (see Section 
10.1). 

The Open Multi-Banded image window is displayed.   

2.  Click on the Color Assignment tab. 

The Color Assignment panel is displayed (see Figure 10.4). 

3.  Select the files to be assigned to each band (RGB). 

4.  (Optional) Select the appropriate radio button and provide a 
constant to be used for the alpha channel, or select an image 
from the dropdown list. 

5.  (Optional) Check the checkbox to indicate whether or not to load 
the remaining channels. 

6.  Click on the Apply button to generate an image based on your 
selection (you can do this several times) and/or on the OK button 
to generate the image and close the dialog window. 

 

Figure 10.4: The 
Open Multi-
Banded Image 
Window: Color 
Assignment 
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10.3 Editing Multi-Band Images 
 

Editing a 
Multi-banded 
image 

You can edit either a multi-layered image, creating a composite image (as 
described above) or create a multi-layer image out of a composite image.   

  

 To edit the multi-banded image, once it has been created: 

1.  Pull down the View menu and select Image Layers to view the 
Layers window. 

2.  Click on the Display button. 

The Multiband/Layers operation window is displayed.  This 
window is identical to the Open Multi-Banded Image 
window. 

3.  Follow the steps in Section 10.2 to either create a multi-layered 
image from a composite, or to create a composite from multiple 
layers. 



 10 Working With Stacks 
 

  123 

11 Working with Stacks 
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11.1 Creating a Stack from Multiple Images 
 

Overview You may wish to create a stack from a group of images that are currently 
opened as separate images.  NASA Image2000 allows you to both create a stack 
from open image windows, and to create a set of open image windows from a 
stack.  This section discusses the process for creating a stack.   

Note: Due to limitations in the development environment, NASA Image2000 currently 
is unable to save multi-image filetypes (including multi-layer images and 
stacks).  As a workaround, NASA Image2000 saves each layer or stack image as 
a separate image.  NASA Image2000 places the group of layer or stack images in 
a separate directory.   The user can therefore, at a later time, choose to open the 
images as either a multi-band, multi-layer image or as a stack, or can choose to 
work with the images as separate images (see Section 7.1). 
  

 To create a stack from open images: 

1.  Make sure that the images you want to use for the stack are 
open. 

2.  Arrange the image in the order you want them to appear in the 
stack by selecting each image in reverse order.  The image in 
front will be the first image, the next image back will be the 
second, and so on. 

Note: It may be helpful to “Cascade” the windows 
while performing this step.  Pull down the 
Window menu and select Cascade. 

3.  Pull down the Stack menu and select Windows to Stack> and 
either Include All Layers or Current Layer Only. 

The single image windows close, and a new unsaved stack 
is displayed (see Figure 11.1). 

•  If you choose to include all layers, each layer contained 
in the open images will be saved as a separate image in 
the stack. 

•  If you choose to include only the current layer, the 
selected layer in each image frame will be included in 
the stack as a separate image.   

•  If the images in question contain only a single layer, the 
results will be the same with either option. 

4.  To Save the new stack: 

 Pull down the File menu and choose Save OR 

 Click on the Save icon on the toolbar.   

 The new stack is saved.  
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Figure 11.1: A 
New Stack 
Window 
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11.2 Animating a Stack of Images 
 

Overview One of the most important applications for a stack of image is animation.  
Animating a stack can emphasize gradual changes across a series of images 
(e.g., weather changes, or changes in ozone levels). You can manually imitate 
the process of animating the stack by simply clicking on the “handle” of the 
slider (at the bottom of the stack window)  and dragging it to the right (to 
animate “forward”).  NASA Image2000 also, however, provides an automated 
animation feature, which provides several options. 
 

 To animate an open stack: 

1.  Pull down the Stack menu and select Animate…   

The Animate Stack window is displayed (see Figure 11.2). 

2.  (Optional) For “quick” animation, accept the default radio button 
selection of Frames/Second(1-30), and edit the text field to 
define the speed of the animation (in frames per second). 

3.  (Optional) For a slower animation, more like a slide show, click in 
the Seconds/Frame radio button and define the number of 
seconds each frame should display. 

4.  (Optional) Deselect the Loop check box to allow the animation to 
play only a single time, or leave it checked to allow the animation 
to play indefinitely. 

5.  Click on the Start button to start the animation.   

6.  (Optional) You can click the Stop button at any time to stop the 
animation.  When the animation is stopped, you can click on the 
Rewind button to start the animation over at the beginning. 

7.  Click in the close box in the upper right-hand corner of the 
window to close the Animate Stack window. 
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Figure 11.2: The 
Animate Stack 
Window 
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11.3 Displaying Stack Images using Montage 
 

Overview You may find it useful to gain a high-level overview of stack images, as opposed 
to viewing the images one at a time.  NASA Image2000 provides the ability to 
view a montage of images of a stack, which creates a new image with  a mosaic 
view of thumbnail versions of the stack images.  You may choose to include all 
stack images or customize the contents of the montage.  You may also choose to 
save the montage image for later use. 
  

 To create a basic montage from an open stack (using the default selections 
and including all stack image in the montage): 

1.  Pull down the Stack menu and select Montage… .   

The Create Montage window is displayed (see Figure 11.3). 

2.  Click on the OK button to create the montage, or on the Cancel 
button to cancel the operation. 

A new untitled image window is displayed, providing a 
montage of thumbnail versions of the stack images.   

3.  To Save the new montage image: 

 Pull down the File menu and choose Save OR 

 Click on the Save icon on the toolbar.   

The Save window is displayed, allowing you to provide a 
filename and save the image. 

 

Figure 11.3: The 
Create 
Montage 
Window 
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Figure 11.4 
Untitled 
Montage 
Image Window 
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11.4 Customizing the Stack Montage 
 

Overview You may choose to include all stack images or customize the contents of the 
montage.  You may also choose to customize certain layout and display features 
of the montage. This section provides instructions for customizing the stack 
montage 
  

 To create a customized montage from an open stack (changing the layout of the 
montage or specifying the stack images to include in the stack): 

1.  Pull down the Stack menu and select Montage… .   

The Create Montage window is displayed (see Figure 11.5). 

2.  (Optional) Customize the layout of the montage: 

 a. (Optional) Enter the percentage to which you wish the stack 
images scaled in the Scale(%) text field. 

 b. (Optional) Edit the number of Rows and Columns to redefine the 
grid layout for the montage. 

 c. (Optional) Select the appropriate radio button to redefine the 
order in which the images will be placed (Row, then Column, or 
Column, then Row).   

3.  (Optional) Customize the borders and labels used in the montage: 

 a. Click on the Options tab. 

The Options tab is displayed (see Figure 11.6) 

 b. (Optional) Click to unselect the Border Images checkbox remove 
the borders OR edit the Size (in pixels) and Color of the border. 

 c. (Optional) Click in the checkboxes to include or exclude labels. 

 d. (Optional) If you are including labels, edit the label’s Font Size 
and/or Color. 

4.  (Optional) To manually select the images you wish to include in the 
montage: 

 a. (If necessary) Click on the Basic Layout tab. 

 b. Click on the Images: Select radio button. 

The Image Selection window is displayed (see Figure 11.7) 

 c. Click in the text boxes to select/deselect the images you wish to 
include in the montage OR click on the buttons to Select All or 
Deselect All. 

 d. When your selection is complete, click on OK to accept the 
selection, or Cancel to cancel. 

5.  (Optional) To automatically select the images you wish to include in 
the montage, based on a numerical increment: 
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 a. Click on the Advanced Layout tab. 

The Advanced Layout tab is displayed (see Figure 11.6) 

 b. Edit the Increment text field to define which images to include 
(e.g., every <2> images in the stack). 

 c. Edit the First Image and Last Image text fields to define the first 
and last images to include. 

6.  Click on the OK button to create the montage, or on the Cancel 
button to cancel the operation. 

A new untitled image window is displayed, providing a montage 
of thumbnail versions of the stack images.   

7.  To Save the new montage image: 

 Pull down the File menu and choose Save OR 

 Click on the Save icon on the toolbar.   

The Save window is displayed, allowing you to provide a filename 
and save the image. 

 

Figure 11.5: The 
Options section 
of the Create 
Montage 
Window. 

 
 

Figure 11.6: The 
Advanced 
Layout section 
of the  Create 
Montage 
Window 
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11.5 Altering the Stack (Extracting, Duplicating, 
Inserting and Deleting) 

 

Overview NASA Image2000 provides several options for altering a stack. Many 
enhancement and analysis options are only available in single-image mode.  
You may therefore wish to extract an image from a stack (removing an image 
from the stack, but allowing it to be edited as a single image) or duplicate the 
image (creating a copy of the image which may be edited, but leaving the 
original image in the stack).  In addition, you may wish to change the 
configuration of a stack by inserting an image into an existing stack, (either to 
add a new image to the stack or to return an extracted image to its place in the 
stack) or by deleting an image from the stack.   
 

Extracting 
Images 

When you extract an image from the stack, the image is removed from the stack 
and displayed as a single image.     
  

 To extract an image from an open stack: 

1.  Bring the image you wish to extract to the top of the stack. 

2.  Pull down the Stack menu and select Extract.   

The Image window is displayed, along with single-image 
windows (like the Tool Layer windows). 

 

Duplicating 
Images 

Duplicating a stack image creates a new, untitled copy of the image in view on 
the stack when the operation is performed.  The duplicated image appears in a 
standard image window, and may be edited and analyzed as needed.    The 
original image remains in its place in the stack. 
  

 To duplicate an image in an open stack: 

1.  Bring the image you wish to duplicate to the top of the stack. 

2.  Pull down the Stack menu and select Duplicate.   

A new, untitled Image window is displayed, along with single-
image windows (like the Tool Layer windows). 

 

Inserting 
Images 

When you insert an image, a copy of the image is inserted into the stack.  The 
image’s new location in the stack is determined by the view of the stack when 
the insert operation is performed: the image is inserted before the top-most 
image in the stack.  The single image window remains open and editable.  After 
the image is inserted into the stack, further edits to the single image are not 
reflected in the stack image.   
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 To insert an open image into an open stack: 

1.  Scroll through the stack to find the location at which you wish to 
insert the image.  (The image will be inserted before the image in view 
when the operation is performed.) 

2.  Pull down the Stack menu and select Insert…. 

The Image Selection Window is displayed (see Figure 11.7). 

3.  Click on the check boxes to select the image you want to insert.  (Use 
Select All or Deselect All buttons as needed.) 

4.  Click on the OK  button to insert the image, or on the Cancel button 
to cancel the operation. 

The image is inserted into the stack. 
 

Figure 11.7: The 
Image Selection 
Window. 

 
 

Deleting 
Images 

Deleting a stack image removes the image from the stack.   If the stack was 
created from a directory of image files, the corresponding image file is not 
deleted, and the image can therefore be retrieved at a later time.    
  

 To delete an image from an open stack: 

1.  Bring the image you wish to delete to the top of the stack. 

2.  Pull down the Stack menu and select Delete.   

The image is removed from the stack. 
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11.6 Using Overlays with a Stack  
 

Overview NASA Image2000 allows you to apply an overlay to a stack of images.  Overlays 
can be useful when viewing stack animations, to visualize changes in reference 
to unmoving data.  For example, you might apply an overlay to show 
geographical borders on a stack which displays changes in ozone values, in 
order to easily identify the location of the changes in ozone values. 

Overlays must match the stack images in size and dimension.  In addition, the 
overlay image must be the same image type as the stack images.  (An overlay 
can be thought of as another image in the stack, in that it must match the 
stack images.  In this case, however, the overlay image is superimposed over 
each image in the stack.) 
 

Adding an 
Overlay 

You can add an overlay to a stack either from a file or an open image.  In both 
cases, however, remember that the file size and type of the overlay must match 
the stack. 
  

 To add an overlay from a file: 

1.  Pull down the Stack menu and select Overlays>Overlay from File. 

The Open File window is displayed. 

2.  Select the overlay file you wish to use, and click on the Open button.   

The stack is rendered, with the overlay image superimposed over 
each stack image. 

 

 To add an overlay from an open image: 

1.  Pull down the Stack menu and select Overlays>Overlay from Open 
Images. 

The Image Selection window is displayed (see Figure 11.8). 

2.  Click on the Deselect All button so that no image is selected. 

3.  Click on the check box to select the overlay image you wish to use. 

4.  Click on the OK button.   

The stack is rendered, with the overlay image superimposed over 
each stack image. 

 

Identifying 
Transparent 
Pixel Values 

Since the overlay is superimposed over the stack images, you may want to 
identify a “transparent pixel” value.  For example, if your overlay has a black 
background, you may want to specify the color black (pixel value 0) as 
transparent so that the background does not obscure the stack images.  This 
transparent pixel value is used only for the overlay image, and will not affect the 
stack images themselves. 
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 To specify a transparent pixel value: 

1.  Pull down the Stack menu and select Overlays>Choose Overlays 
Transparent Pixel Value. 

The Transparent Pixel Value dialog is displayed. 

2.  Enter the pixel value (between 0 and 255) in the text field, and click 
on the OK button.   

The stack is rendered, with the specified pixel value in the 
overlay image appearing transparent. 

 

Removing an 
Overlay from 
the Stack 

You can choose to either remove an overlay or to extract it.  If you remove the 
overlay, the overlay image is simply removed from the stack.  If you extract it, 
the overlay image is removed from the stack, but displayed in a new image 
window to allow you to work with it. 
  

 To remove an overlay from the stack: 
Pull down the Stack menu and select Overlays>Remove Overlays. 

  The overlay is removed from the stack. 
 

 To extract an overlay from the stack: 
Pull down the Stack menu and select Overlays>Extract Overlays. 

  The overlay is removed from the stack, and appears in a new 
image untitled image window. 
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11.7 Using Projections with a Stack 
 

Overview Map projections are used to represent a spherical object (like the Earth) on a 
flat surface like paper or a computer screen.  Unprojected map images are very 
distorted. For example, the surface area of a pixel on the equator may differ 
greatly from the surface area of a pixel near the poles.  Map projections 
minimize these distortions.  NASA Image2000 provides four map projections 
operations for stacks, which may be used with geocoded stacks 
 

Options The following map projection operations are available: 
 

Equirectangular Used to remove projections, 
returning the stack to the 
original view. 

Goode This projection is used to 
display global data.  The 
projection is an equal area 
projection, but the globe is 
interrupted so that all of 
the land masses (except 
Antarctica) are continuous, 
which helps to preserve the 
shape of land masses. 

Hammer This projection is also used 
to display global data, but 
the globe is presented as a 
continuous feature.  You 
have the option to define 
the center longitude for the 
projection, which allows 
you to control the portion 
of the globe that appears in 
the center of the image 
window. 
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Polar This projection shows the 
North or South poles of the 
Earth as viewed from deep 
space.  The polar regions 
are often severely distorted 
by other projections.  This 
projection allows you to 
choose to view the North or 
South Pole.  

  

Before you 
begin 

Make sure the stack you are using is made of geocoded images.  You may define 
geocoding information for certain images when opening the image.  See Section 
3.1.   
 

 To apply a map projection: 

1.  Pull down the Stack menu, select Project Stack>, and choose 
the desired projection menu item. 

2.  (Optional) If you selected Goode, no further parameters are 
necessary. 

The image is updated, with the Goode projection applied. 

3.  (Optional) If you selected Hammer, enter the Reference Longitude 
in the text box, and click OK. 

The image is updated, with the Hammer projection applied. 

4.  (Optional) If you selected Polar, choose the appropriate radio 
button for either the North or South Pole, and click OK. 

The image is updated, with the Polar projection applied. 
 

 To remove a map projection (displaying the unprojected stack): 
Pull down the Stack menu, select Project Stack> Equirectangular.   

  The stack is updated, displaying the unprojected image. 
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11.8 Performing Analysis on a Stack (Profiles, 
Measurements) 

  

Overview NASA Image2000 allows you to perform various calculations and measurements 
on a stack, as well as performing profile operations.  In many cases, the stack 
measurements are performed just as you would on a single image.  Before the 
measurements will work, however, you must first “tell” NASA Image2000 to 
Record Measurements. 
 

 To Record Measurements: 

1.  Pull down the Stack menu, and select Record Measurements. 

2.  Pull down the Image menu item, and select Analyze>Measure, 

or click on the Measure icon  . 

3.  To view the recorded measurements, pull down the Image menu 
and select Analyze>Measurement Table. 

  

Plot Profiles You can plot profiles on a stack of images just as you would on a single image 
(see Section 6.5).  In addition, NASA Image2000 provides another stack 
specifically for use with stacks, the Z-Profile.  This feature plots a profile based 
on a selection of a region of interest, graphing the range of pixels represented 
through the stack. 

For example, a series of 40 monthly images of NDVI may be put into a stack.  
The Z-Profile of NDVI for a region, which represents a time-series of NDVI over 
40 months, is plotted in Figure 11.8. 
 

 To plot a Z-Profile: 

1.  Select the region of interest you wish to profile, using one of the 
selection tools (see Section 6.1). 

2.  Pull down the Stack menu, and select Z-Profile. 

The Stack Z-Profile window is displayed (see Figure 11.8). 



 10 Working With Stacks 
 

  139 

 

Figure 11.8: The 
Z-Profile 
window. 
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11.9 Calculating Stack Statistics 
  

Overview NASA Image2000 allows you to create a separate image from a stack, in which 
each pixel in the image is the result of a calculation of all the corresponding 
pixels in each stack slice.  For example, you can calculate the Mean of the 
stack, and the resulting image would be one in which each pixel value is 
calculated as the mean of the corresponding pixel in each of the stack images 
(see Figure 7.11 and following list). 
 

Figure 7.11: 
Montage of 
Example Stack 
Images 

  

Stack 
Statistic  
Calculation 
Effects 

NASA Image2000 allows you to calculate the following stack statistics, which 
in the case of the above example, achieve the following effects: 

Mean 

 
Minimum 
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Maximum 

 
CoV- 
Coefficient 
of Variation 

 
Standard 
Deviation 

 
 

 
To calculate stack statistics:  

 Pull down the Stack menu and select Statistics> <Selected Statistic>. 

A new Image window is displayed with a composite image calculated by 
the selected calculation.  You can see the changed value for a given pixel 
by using the Image Info Window. 
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